summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2016-03-05 12:06:46 -0800
committermutantmonkey2016-03-05 12:06:46 -0800
commit5b87808fecc6a5400088c44f204bdaa12d66b24a (patch)
treea7a2988c8ba305bda37e65ebaffff7ba51bf8fac
parent873410dd1aeb8f22141f6a0bed944751288cdb51 (diff)
downloadaur-info-beamer-git.tar.gz
upgpkg: info-beamer-git 243.ac815b1-3
Apply ffmpeg_2.9.patch from Debian (thanks qs9rx for the tip) to get it building against the latest ffmpeg.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--ffmpeg_2.9.patch35
3 files changed, 47 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b265f42ea7a9..2482b9a9483f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Mar 5 19:59:12 UTC 2016
+# Sat Mar 5 20:06:46 UTC 2016
pkgbase = info-beamer-git
pkgdesc = Allows you to develop interactive information displays using the Lua programming language.
pkgver = 243.ac815b1
- pkgrel = 2
+ pkgrel = 3
url = https://info-beamer.com/opensource
arch = i686
arch = x86_64
license = BSD
makedepends = git
- depends = ffmpeg2.8
+ depends = ffmpeg
depends = lua51
depends = libevent
depends = glfw
@@ -17,7 +17,9 @@ pkgbase = info-beamer-git
depends = glew
depends = ftgl
source = git+https://github.com/dividuum/info-beamer.git
+ source = ffmpeg_2.9.patch
sha256sums = SKIP
+ sha256sums = 695713eb1f806ffc8f50cf44575fb071350f11f2b2f456c3fca53e07a560c657
pkgname = info-beamer-git
diff --git a/PKGBUILD b/PKGBUILD
index bd95ee8009fc..755d5c29d44b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,17 @@
pkgname=info-beamer-git
_gitname=info-beamer
pkgver=243.ac815b1
-pkgrel=2
+pkgrel=3
pkgdesc="Allows you to develop interactive information displays using the Lua programming language."
arch=('i686' 'x86_64')
url="https://info-beamer.com/opensource"
license=('BSD')
-depends=('ffmpeg2.8' 'lua51' 'libevent' 'glfw' 'devil' 'glew' 'ftgl')
+depends=('ffmpeg' 'lua51' 'libevent' 'glfw' 'devil' 'glew' 'ftgl')
makedepends=('git')
-source=('git+https://github.com/dividuum/info-beamer.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/dividuum/info-beamer.git'
+ 'ffmpeg_2.9.patch')
+sha256sums=('SKIP'
+ '695713eb1f806ffc8f50cf44575fb071350f11f2b2f456c3fca53e07a560c657')
pkgver() {
cd $_gitname
@@ -24,8 +26,7 @@ prepare() {
sed -i 's/GL\/glfw.h/GLFW\/glfw3.h/g' font.c
sed -i 's/GL\/glfw.h/GLFW\/glfw3.h/g' shader.c
sed -i 's/#define _BSD_SOURCE/#define _DEFAULT_SOURCE/g' vnc.c main.c
- sed -i 's/-I\/usr\/include\/ffmpeg/-I\/usr\/include\/ffmpeg2.8/g' Makefile
- sed -i 's/avcodec_alloc_frame/av_frame_alloc/g' video.c
+ patch -Np1 -i ../ffmpeg_2.9.patch
}
build() {
diff --git a/ffmpeg_2.9.patch b/ffmpeg_2.9.patch
new file mode 100644
index 000000000000..b14b78007b0f
--- /dev/null
+++ b/ffmpeg_2.9.patch
@@ -0,0 +1,35 @@
+diff -aur info-beamer/video.c info-beamer.patched/video.c
+--- info-beamer/video.c 2016-03-04 19:40:01.074477127 +0100
++++ info-beamer.patched/video.c 2016-03-04 19:40:40.991262568 +0100
+@@ -64,9 +64,9 @@
+ if (video->scaler)
+ sws_freeContext(video->scaler);
+ if (video->raw_frame)
+- av_free(video->raw_frame);
++ av_frame_free(&video->raw_frame);
+ if (video->scaled_frame)
+- av_free(video->scaled_frame);
++ av_frame_free(&video->scaled_frame);
+
+ if (video->codec_context)
+ avcodec_close(video->codec_context);
+@@ -78,7 +78,7 @@
+
+ static int video_open(video_t *video, const char *filename) {
+ video->finished = 0;
+- video->format = PIX_FMT_RGB24;
++ video->format = AV_PIX_FMT_RGB24;
+
+ if (avformat_open_input(&video->format_context, filename, NULL, NULL) ||
+ avformat_find_stream_info(video->format_context, NULL) < 0) {
+@@ -143,8 +143,8 @@
+ fprintf(stderr, INFO("fps: %lf\n"), video->fps);
+
+ /* Get framebuffers */
+- video->raw_frame = avcodec_alloc_frame();
+- video->scaled_frame = avcodec_alloc_frame();
++ video->raw_frame = av_frame_alloc();
++ video->scaled_frame = av_frame_alloc();
+
+ if (!video->raw_frame || !video->scaled_frame) {
+ fprintf(stderr, ERROR("cannot preallocate frames\n"));