summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlavi Pantaleev2018-04-13 17:15:34 +0200
committerSlavi Pantaleev2018-04-13 17:15:34 +0200
commita41bab9ee158c4324663b08efeec36e9f4478157 (patch)
tree0144bb4d251bd2f1db7e5cf3bd114a9f25e7ca50
downloadaur-a41bab9ee158c4324663b08efeec36e9f4478157.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--infonotary-client-software.install5
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00c1bd176de1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = infonotary-client-software
+ pkgdesc = InfoNotary client software - InfoNotary e-Doc Signer and InfoNotary Smart Card Manager.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = http://www.infonotary.com/
+ install = infonotary-client-software.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = qt5-base
+ depends = nss
+ depends = openssl
+ optdepends = ccid: generic USB Chip/Smart Card Interface Devices driver
+ optdepends = omnikey_ifdokccid-git: driver for OmniKey smart card readers
+ optdepends = bit4id-ipki: driver for T&S DS/2048 (L) smart cards
+ optdepends = pcsclite: smartcard middleware library (pcscd)
+ optdepends = pcsc-tools: smartcard tools (pcsc_scan)
+ optdepends = opensc: a set of libraries and utilities to work with smart cards
+ conflicts = infonotary-scardmanager
+ replaces = infonotary-scardmanager
+ source = http://repository.infonotary.com/install/linux/DEBS/pool/non-free/i/infonotary-client-software/infonotary-client-software_2.0.3.845_amd64.deb
+ md5sums = 861abc574ce689e6c9c9a4007da70d94
+
+pkgname = infonotary-client-software
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d202d1327fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+pkg
+src
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6df7f2bec4d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Slavi Pantaleev <slavi at devture.com>
+
+pkgname=infonotary-client-software
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="InfoNotary client software - InfoNotary e-Doc Signer and InfoNotary Smart Card Manager."
+arch=('i686' 'x86_64')
+url="http://www.infonotary.com/"
+license=('unknown')
+depends=(qt5-base nss openssl)
+replaces=(infonotary-scardmanager)
+conflicts=(infonotary-scardmanager)
+optdepends=(
+ 'ccid: generic USB Chip/Smart Card Interface Devices driver'
+ 'omnikey_ifdokccid-git: driver for OmniKey smart card readers'
+ 'bit4id-ipki: driver for T&S DS/2048 (L) smart cards'
+ 'pcsclite: smartcard middleware library (pcscd)'
+ 'pcsc-tools: smartcard tools (pcsc_scan)'
+ 'opensc: a set of libraries and utilities to work with smart cards'
+)
+install=$pkgname.install
+
+if [ "${CARCH}" = 'x86_64' ]; then
+ ARCH='amd64'
+ md5sums=('861abc574ce689e6c9c9a4007da70d94')
+else
+ ARCH='i386'
+ md5sums=('942dc34d3b023696ccfde0a7e27a9dd5')
+fi
+
+_file_name=$pkgname'_'$pkgver'.845_'$ARCH'.deb'
+source=('http://repository.infonotary.com/install/linux/DEBS/pool/non-free/i/infonotary-client-software/'$_file_name)
+
+package() {
+ ar -xv $_file_name || return 1
+ tar -xvf data.tar.[xg]z -C $pkgdir || return 1
+}
diff --git a/infonotary-client-software.install b/infonotary-client-software.install
new file mode 100644
index 000000000000..f05aed65a2ec
--- /dev/null
+++ b/infonotary-client-software.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo -n "If your card requires a custom driver (like bit4id-ipki),"
+ echo " you'll need to edit Preferences and add its module there (/usr/lib/libbit4ipki.so in this case)."
+}
+