summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-07-19 00:24:25 -0500
committerlibele2022-07-19 00:24:25 -0500
commit1ad857e6105a07fe8d974da15848555ace19d825 (patch)
tree228cbcfc04f8213c26a454c1c6784af9f6e45685
parentc254703ca37fab89a9a2cec9a08778792e1d577f (diff)
downloadaur-1ad857e6105a07fe8d974da15848555ace19d825.tar.gz
inform 6.40.r1.0.gac1b4f1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6109574c03f4..08433383dc6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = inform-git
- pkgdesc = Interactive fiction compiler (git version)
- pkgver = 6.36.r3.1.ga76ac16
+ pkgdesc = The Inform 6 compiler, standard library, and PunyInform library (git version)
+ pkgver = 6.40.r1.0.gac1b4f1
pkgrel = 1
- url = http://www.inform-fiction.org/
+ url = https://gitlab.com/DavidGriffith/inform6unix
arch = aarch64
arch = arm
arch = armv6h
arch = armv7h
+ arch = i486
arch = i686
arch = pentium4
arch = x86_64
groups = inform
license = Artistic2.0
license = MIT
- provides = inform
+ makedepends = git
+ depends = perl
+ depends = ruby
+ provides = punyinform=4.0
conflicts = inform
source = git+https://gitlab.com/DavidGriffith/inform6unix.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 51477fc14d6b..114ddd34371b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
-# maintainer: libele <libele@disroot.org>
+# Maintainer: libele <libele@disroot.org>
pkgname=inform-git
_gitpkg=inform6unix
-pkgver=6.36.r3.1.ga76ac16
+pkgver=6.40.r1.0.gac1b4f1
pkgrel=1
-pkgdesc="Interactive fiction compiler (git version)"
-arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'pentium4' 'x86_64')
-url="http://www.inform-fiction.org/"
+pkgdesc="The Inform 6 compiler, standard library, and PunyInform library (git version)"
+arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
+url="https://gitlab.com/DavidGriffith/inform6unix"
license=('Artistic2.0' 'MIT')
provides=('inform')
conflicts=('inform')
groups=(inform)
+depends=('perl' 'ruby')
+makedepends=('git')
+provides=('punyinform=4.0')
source=('git+https://gitlab.com/DavidGriffith/inform6unix.git')
md5sums=('SKIP')
@@ -44,6 +47,16 @@ package() {
cd "${srcdir}/${_gitpkg}-dev"
make REAL_PREFIX=/usr PREFIX="${pkgdir}"/usr MAN_PREFIX="${pkgdir}"/usr/share install-alt
+ cd "${pkgdir}"/usr/share/inform/std/lib
+ install -Dm644 ARTISTIC "${pkgdir}"/usr/share/licenses/inform/ARTISTIC
+
+ cd "${pkgdir}"/usr/share/inform/punyinform
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/punyinform/LICENSE
+
+ cd "${pkgdir}"/usr/man/man1
+ install -Dm644 inform.1 "${pkgdir}"/usr/share/man/man1/inform.1
+ rm -rf "${pkgdir}"/usr/man
+
cd "${pkgdir}"/usr/bin
rm pblorb scanblorb
}