summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-09-01 19:09:39 -0500
committerlibele2022-09-01 19:09:39 -0500
commit18af67322654ac1b954ccbf43d3c8b10f6eb98fe (patch)
treedeab2be5bffb7c805348ca0a4ff370f6452cc7f3
parent7f1cba445dcd4b14972e4678ca61875bff18ba4b (diff)
downloadaur-18af67322654ac1b954ccbf43d3c8b10f6eb98fe.tar.gz
version 10.2.0.beta+6V49
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD58
-rw-r--r--inform7.install3
-rw-r--r--make-integration-settings.mk6
-rwxr-xr-xwrapper.sh4
5 files changed, 48 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ec1e369a207..7c87c1df9560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = inform7-git
pkgdesc = A design system for interactive fiction based on natural language (git version)
- pkgver = r1507.e3bcfd85a
+ pkgver = 10.2.0.beta+6V49
pkgrel = 1
url = https://ganelson.github.io/inform
- install = inform7.install
arch = aarch64
arch = arm
arch = armv6h
arch = armv7h
+ arch = i486
arch = i686
arch = pentium4
arch = x86_64
groups = inform
license = Artistic2.0
+ makedepends = git
makedepends = rsync
provides = inform
provides = inform7
@@ -27,7 +28,7 @@ pkgbase = inform7-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = e068ffd6869177fae89a34dbe96bdf5d
- md5sums = 88a7cefc597fdc719866b72c256166c6
+ md5sums = c2ab103343c837e3d4f74eb4ea3748f5
+ md5sums = 07fb211a928d44d3cf221f3760911957
pkgname = inform7-git
diff --git a/PKGBUILD b/PKGBUILD
index 9924042a56f7..62277b9f4a60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# maintainer: libele <libele@disroot.org>
+# Maintainer: libele <libele@disroot.org>
pkgname=inform7-git
+_pkgname=inform7
_gitpkg=inform
-pkgver=r1507.e3bcfd85a
+pkgver=10.2.0.beta+6V49
pkgrel=1
pkgdesc="A design system for interactive fiction based on natural language (git version)"
-arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'pentium4' 'x86_64')
+arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://ganelson.github.io/inform"
license=('Artistic2.0')
-makedepends=('rsync')
+makedepends=('git' 'rsync')
provides=('inform' 'inform7')
conflicts=('inform7')
groups=(inform)
-install=inform7.install
options=(!buildflags !makeflags)
source=('git+https://github.com/ganelson/inform'
@@ -24,38 +24,54 @@ source=('git+https://github.com/ganelson/inform'
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'e068ffd6869177fae89a34dbe96bdf5d'
- '88a7cefc597fdc719866b72c256166c6')
+ '085007a124028daedf369c0fa0549b2a'
+ '07fb211a928d44d3cf221f3760911957')
pkgver() {
- cd "${_gitpkg}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_gitpkg"
+ head -n 3 < README.md | tail -n 1 | cut -d ' ' -f 2 | sed 's/-/./g'
}
build() {
- cd "${srcdir}"
+ cd "$srcdir"
bash inweb/scripts/first.sh linux
bash intest/scripts/first.sh
- cd "${_gitpkg}"
+ cd "$_gitpkg"
bash scripts/first.sh
../intest/Tangled/intest inform7 -show Acidity
- make check
+ make
+
+ make retrospective
+}
- # make -C .. -f inweb/inweb.mk
- # make -C .. -f intest/intest.mk
- # make
+check() {
+ cd "$_gitpkg"
+ make check
}
package() {
- cd "${_gitpkg}"
+ cd "$_gitpkg"
make forceintegration
- # make retrospective
- # cp -a retrospective DEST
- cd "${srcdir}"
- cp -a dist/* "${pkgdir}"
+ cd "$srcdir"
+ cp -a dist/* "$pkgdir"
+
+ install -Dm755 wrapper.sh "$pkgdir/usr/bin/inform7"
+
+ cd "$srcdir/inform/retrospective/6L02"
+ install -Dm755 cBlorb "$pkgdir/usr/lib/$_pkgname/retrospective/6L02/cBlorb"
+ install -Dm755 ni "$pkgdir/usr/lib/$_pkgname/retrospective/6L02/ni"
+ cp -ar Extensions "$pkgdir/usr/lib/$_pkgname/retrospective/6L02/Extensions"
+
+ cd ../6L38
+ install -Dm755 cBlorb "$pkgdir/usr/lib/$_pkgname/retrospective/6L38/cBlorb"
+ install -Dm755 ni "$pkgdir/usr/lib/$_pkgname/retrospective/6L38/ni"
+ cp -ar Internal "$pkgdir/usr/lib/$_pkgname/retrospective/6L38/Internal"
- install -Dm755 wrapper.sh "${pkgdir}/usr/bin/inform7"
+ cd ../6M62
+ install -Dm755 cBlorb "$pkgdir/usr/lib/$_pkgname/retrospective/6M62/cBlorb"
+ install -Dm755 ni "$pkgdir/usr/lib/$_pkgname/retrospective/6M62/ni"
+ cp -ar Internal "$pkgdir/usr/lib/$_pkgname/retrospective/6M62/Internal"
}
diff --git a/inform7.install b/inform7.install
index ca1ee8720a52..2c4714426075 100644
--- a/inform7.install
+++ b/inform7.install
@@ -1,5 +1,4 @@
post_install() {
- echo -e "-> The inform compiler binaries have been installed as i6 and i7."
- echo -e "-> Documentation and libraries can be found under /usr/share/inform7."
+ echo -e "-> The inform compiler binaries have been installed as i6 and ni."
echo -e "-> For convenience, a wrapper is provided to set the inform7 library path."
}
diff --git a/make-integration-settings.mk b/make-integration-settings.mk
index e62257e7fbfa..ccd85e8d6103 100644
--- a/make-integration-settings.mk
+++ b/make-integration-settings.mk
@@ -1,13 +1,13 @@
INTEGRATION=1
BUILTINCOMPS=../dist/usr/bin
-INTERNAL=../dist/usr/share/inform7
+INTERNAL=../dist/usr/lib/inform7
INBLORBNAME=inblorb
INFORM6NAME=i6
-INFORM7NAME=i7
+INFORM7NAME=ni
INTESTNAME=intest
-BUILTINHTML=$(INTERNAL)/Documentation/
+BUILTINHTML=../dist/usr/share/doc/inform7
BUILTINHTMLINNER=$(BUILTINHTML)
INDOCOPTS=-to $(BUILTINHTML) website
diff --git a/wrapper.sh b/wrapper.sh
index 12202055b419..1a08f071f648 100755
--- a/wrapper.sh
+++ b/wrapper.sh
@@ -1,7 +1,7 @@
#!/bin/sh
-LIBPATH=/usr/share/inform7
-INFORM7=/usr/bin/i7
+LIBPATH=/usr/lib/inform7
+INFORM7=/usr/bin/ni
if [ -z "$1" ] || [ "$1" = "-help" ] || [ "$1" = "--help" ];
then $INFORM7 -help;