summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-05-04 16:31:20 -0500
committerlibele2022-05-04 16:31:20 -0500
commitb8356bf6b8dcd7efa9ee3ff3759365ca2bfee235 (patch)
treea75e0119d99d53922acc7a57239e12bbc9d0cf49
parentf4859b529d0bd25dc8e204ec8abd8b1ca94c865d (diff)
downloadaur-b8356bf6b8dcd7efa9ee3ff3759365ca2bfee235.tar.gz
add post_install message, rename compilers to i6 and i7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--inform7.install5
-rw-r--r--make-integration-settings.mk4
-rwxr-xr-xwrapper.sh2
5 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1d60373f6f1..03b757c2b7a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = inform7-git
pkgdesc = A design system for interactive fiction based on natural language (git version)
pkgver = r1395.6ff3fd8db
- pkgrel = 1
+ pkgrel = 2
url = https://ganelson.github.io/inform
+ install = inform7.install
arch = aarch64
arch = arm
arch = armv6h
@@ -23,7 +24,7 @@ pkgbase = inform7-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 97f4a478c9055ef8adc0717b6c23b1af
- md5sums = ddac46959271ebb9fbd31341b7ebd1af
+ md5sums = e068ffd6869177fae89a34dbe96bdf5d
+ md5sums = 88a7cefc597fdc719866b72c256166c6
pkgname = inform7-git
diff --git a/PKGBUILD b/PKGBUILD
index 1c94cccea4a7..6850c3f3b1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
pkgname=inform7-git
_gitpkg=inform
-_mirror="https://ifarchive.org"
pkgver=r1395.6ff3fd8db
-pkgrel=1
+pkgrel=2
pkgdesc="A design system for interactive fiction based on natural language (git version)"
arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'pentium4' 'x86_64')
url="https://ganelson.github.io/inform"
@@ -12,6 +11,7 @@ license=('Artistic2.0')
provides=('inform' 'inform7')
conflicts=('inform7')
groups=(inform)
+install=inform7.install
source=('git+https://github.com/ganelson/inform'
'git+https://github.com/ganelson/inweb'
@@ -22,8 +22,8 @@ source=('git+https://github.com/ganelson/inform'
md5sums=('SKIP'
'SKIP'
'SKIP'
- '97f4a478c9055ef8adc0717b6c23b1af'
- 'ddac46959271ebb9fbd31341b7ebd1af')
+ 'e068ffd6869177fae89a34dbe96bdf5d'
+ '88a7cefc597fdc719866b72c256166c6')
pkgver() {
cd "${_gitpkg}"
@@ -49,8 +49,5 @@ package() {
cd "${srcdir}"
cp -a dist/* "${pkgdir}"
- # moving inform7 binary here for now
- mv "${pkgdir}"/usr/bin/inform7 "${pkgdir}/usr/share/inform7"
-
install -Dm755 wrapper.sh "${pkgdir}/usr/bin/inform7"
}
diff --git a/inform7.install b/inform7.install
new file mode 100644
index 000000000000..ca1ee8720a52
--- /dev/null
+++ b/inform7.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo -e "-> The inform compiler binaries have been installed as i6 and i7."
+ echo -e "-> Documentation and libraries can be found under /usr/share/inform7."
+ echo -e "-> For convenience, a wrapper is provided to set the inform7 library path."
+}
diff --git a/make-integration-settings.mk b/make-integration-settings.mk
index eecb02012751..e62257e7fbfa 100644
--- a/make-integration-settings.mk
+++ b/make-integration-settings.mk
@@ -4,8 +4,8 @@ BUILTINCOMPS=../dist/usr/bin
INTERNAL=../dist/usr/share/inform7
INBLORBNAME=inblorb
-INFORM6NAME=inform6
-INFORM7NAME=inform7
+INFORM6NAME=i6
+INFORM7NAME=i7
INTESTNAME=intest
BUILTINHTML=$(INTERNAL)/Documentation/
diff --git a/wrapper.sh b/wrapper.sh
index 7e0e85b1515f..12202055b419 100755
--- a/wrapper.sh
+++ b/wrapper.sh
@@ -1,7 +1,7 @@
#!/bin/sh
LIBPATH=/usr/share/inform7
-INFORM7="$LIBPATH/inform7"
+INFORM7=/usr/bin/i7
if [ -z "$1" ] || [ "$1" = "-help" ] || [ "$1" = "--help" ];
then $INFORM7 -help;