summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-05-04 13:28:49 -0500
committerlibele2022-05-04 13:28:49 -0500
commitf4859b529d0bd25dc8e204ec8abd8b1ca94c865d (patch)
treef3f97c11b3c83378c379b075ccebe55026302bca
parent16114f66b9a1843b690fb0353231a8aa148f40f0 (diff)
downloadaur-f4859b529d0bd25dc8e204ec8abd8b1ca94c865d.tar.gz
improve wrapper for real this time
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rwxr-xr-xwrapper.sh7
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed5329b572c1..f1d60373f6f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = inform7-git
pkgdesc = A design system for interactive fiction based on natural language (git version)
- pkgver = r1393.16ed0ae71
- pkgrel = 4
+ pkgver = r1395.6ff3fd8db
+ pkgrel = 1
url = https://ganelson.github.io/inform
arch = aarch64
arch = arm
diff --git a/PKGBUILD b/PKGBUILD
index 485443139b1a..1c94cccea4a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname=inform7-git
_gitpkg=inform
-pkgver=r1393.16ed0ae71
-pkgrel=4
+_mirror="https://ifarchive.org"
+pkgver=r1395.6ff3fd8db
+pkgrel=1
pkgdesc="A design system for interactive fiction based on natural language (git version)"
arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'pentium4' 'x86_64')
url="https://ganelson.github.io/inform"
@@ -48,8 +49,8 @@ package() {
cd "${srcdir}"
cp -a dist/* "${pkgdir}"
- # moving i6/7 binaries here for now
- mv "${pkgdir}"/usr/bin/inform[67] "${pkgdir}/usr/share/inform7"
+ # moving inform7 binary here for now
+ mv "${pkgdir}"/usr/bin/inform7 "${pkgdir}/usr/share/inform7"
install -Dm755 wrapper.sh "${pkgdir}/usr/bin/inform7"
}
diff --git a/wrapper.sh b/wrapper.sh
index aa31a9d36e84..7e0e85b1515f 100755
--- a/wrapper.sh
+++ b/wrapper.sh
@@ -2,4 +2,9 @@
LIBPATH=/usr/share/inform7
INFORM7="$LIBPATH/inform7"
-$INFORM7 --no-census-update -internal $LIBPATH "$@"
+
+if [ -z "$1" ] || [ "$1" = "-help" ] || [ "$1" = "--help" ];
+ then $INFORM7 -help;
+elif [ "$1" = "-version" ] || [ "$1" = "--version" ];
+ then $INFORM7 -version;
+else $INFORM7 -no-census-update -internal $LIBPATH "$@"; fi