summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-05-15 16:43:23 -0500
committerlibele2022-05-15 16:43:23 -0500
commit131281b3e242ce1f352973cfd1bfe9434fe652eb (patch)
treed10fe77f03a2d5e71fd9c21ab2b45d28ec0adea6
downloadaur-131281b3e242ce1f352973cfd1bfe9434fe652eb.tar.gz
version 2.0.0.rc2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--inform7-ide.install19
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c4b30dc5769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = inform7-ide-bin
+ pkgdesc = Inform 7 IDE for the Inform 7 programming language for interactive fiction
+ pkgver = 2.0.0.rc2
+ pkgrel = 1
+ url = https://github.com/ptomato/inform7-ide
+ install = inform7-ide.install
+ arch = x86_64
+ groups = inform
+ license = Artistic2.0
+ license = GPL3
+ provides = inform7-ide
+ conflicts = inform7-ide
+ options = !strip
+ source = https://github.com/ptomato/inform7-ide/releases/download/2.0.0-rc2/inform7-ide-2.0.0-1.fc35.x86_64.rpm
+ md5sums = 1508bd979dbb2358a5e044173edb347a
+
+pkgname = inform7-ide-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a0c9ac0ce13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# maintainer: libele <libele@disroot.org>
+
+pkgname=inform7-ide-bin
+pkgver=2.0.0.rc2
+pkgrel=1
+pkgdesc="Inform 7 IDE for the Inform 7 programming language for interactive fiction"
+arch=('x86_64')
+url="https://github.com/ptomato/inform7-ide"
+license=('Artistic2.0' 'GPL3')
+provides=('inform7-ide')
+conflicts=('inform7-ide')
+groups=(inform)
+install=inform7-ide.install
+source=("https://github.com/ptomato/inform7-ide/releases/download/2.0.0-rc2/inform7-ide-2.0.0-1.fc35.x86_64.rpm")
+md5sums=('1508bd979dbb2358a5e044173edb347a')
+options=(!strip)
+
+package() {
+ cd "${srcdir}"
+ cp -a usr "${pkgdir}"/
+ mv "${pkgdir}/usr/lib64"/* "${pkgdir}/usr/lib/"
+ rm -r "${pkgdir}/usr/lib64"
+}
diff --git a/inform7-ide.install b/inform7-ide.install
new file mode 100644
index 000000000000..3f6526d40348
--- /dev/null
+++ b/inform7-ide.install
@@ -0,0 +1,19 @@
+pkgname=inform7-ide
+
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}