summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorАндрей2015-10-30 19:31:47 +0500
committerАндрей2015-10-30 19:31:47 +0500
commita2157f8e14c05e1f6f6247d3dbef1ebc2380cb1c (patch)
treeb318f0af488fcc9f10e63f03b314ee8dd88f32af
downloadaur-a2157f8e14c05e1f6f6247d3dbef1ebc2380cb1c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8639d9113785
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = infornography-git
+ pkgdesc = Racket script to show system information, lightweight alternative to screenfetch.
+ pkgver = 0.2.r7.g9e9c603
+ pkgrel = 1
+ url = https://github.com/telegram-wired/infornography
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = racket
+ source = infornography-git::git+https://github.com/telegram-wired/infornography.git
+ md5sums = SKIP
+
+pkgname = infornography-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c47981081f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: goodmind <andwebar@gmail.com>
+pkgname=infornography-git
+pkgver=0.2.r7.g9e9c603
+pkgrel=1
+pkgdesc="Racket script to show system information, lightweight alternative to screenfetch."
+arch=('any')
+url="https://github.com/telegram-wired/infornography"
+license=('MIT')
+depends=('racket')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/telegram-wired/infornography.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "infornography.rkt" "$pkgdir"/usr/bin/infornography
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+}