summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetamer2017-07-24 20:50:20 -0700
committermetamer2017-07-24 22:30:36 -0700
commit5bd60e100d369b9f2e6f8d039b9d54e37caedd96 (patch)
tree52fefc587e3b90810c78d564dc89c791eb48c6be
parent50c76bc68334939ef03a56a49f39809cdd024592 (diff)
downloadaur-5bd60e100d369b9f2e6f8d039b9d54e37caedd96.tar.gz
v19.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD36
-rw-r--r--rl-utils-numeric-include.patch10
-rw-r--r--room-numeric-include.patch10
4 files changed, 21 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12eadeddb53..a94756781d0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Jul 25 05:30:17 UTC 2017
pkgbase = infra-arcana
pkgdesc = Roguelike game inspired by H.P. Lovecraft
- pkgver = 18.2
+ pkgver = 19.0
pkgrel = 1
url = https://sites.google.com/site/infraarcana/home
install = infra-arcana.install
arch = i686
arch = x86_64
license = custom:Infra Arcana License
+ makedepends = cmake
depends = sdl2_image
depends = sdl2_mixer
depends = hicolor-icon-theme
- source = git+https://github.com/martin-tornqvist/ia.git#tag=v18.2
- source = rl-utils-numeric-include.patch
- source = room-numeric-include.patch
+ source = git+https://github.com/martin-tornqvist/ia.git#tag=v19.0
source = infra-arcana.install
source = infra-arcana.desktop
source = infra-arcana.sh
md5sums = SKIP
- md5sums = fd8cacaa622c4363787cff2e575a8938
- md5sums = 3c05836d84ad451d5d8034267b21ade8
md5sums = 2bc0fb64e8593e25009b1dc50e642cd8
md5sums = 2e28c2803d7d2cd4376dcd3aa6512774
md5sums = 87294b81f5a2f98a78d318a5dcec7caf
diff --git a/PKGBUILD b/PKGBUILD
index f1a288d06757..458482f209cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: metamer <metamer at openmailbox dot org>
+#Maintainer: metamer <metamer at openmailbox dot org>
pkgname=infra-arcana
-pkgver=18.2
+pkgver=19.0
pkgrel=1
epoch=
pkgdesc="Roguelike game inspired by H.P. Lovecraft"
@@ -8,63 +8,59 @@ arch=('i686' 'x86_64')
url="https://sites.google.com/site/infraarcana/home"
license=('custom:Infra Arcana License')
groups=()
+makedepends=(cmake)
depends=('sdl2_image' 'sdl2_mixer' 'hicolor-icon-theme')
#checkdepends=('valgrind')
backup=()
options=()
install=${pkgname}.install
-source=( "git+https://github.com/martin-tornqvist/ia.git"#"tag=v${pkgver}"
- "rl-utils-numeric-include.patch"
- "room-numeric-include.patch"
+source=( git+"https://github.com/martin-tornqvist/ia.git"#"tag=v${pkgver}"
"${pkgname}.install"
"${pkgname}.desktop"
"${pkgname}.sh")
md5sums=('SKIP'
- 'fd8cacaa622c4363787cff2e575a8938'
- '3c05836d84ad451d5d8034267b21ade8'
'2bc0fb64e8593e25009b1dc50e642cd8'
'2e28c2803d7d2cd4376dcd3aa6512774'
'87294b81f5a2f98a78d318a5dcec7caf')
prepare(){
cd $srcdir/"ia"
- cd src
- patch -uN room.cpp $srcdir/room-numeric-include.patch
- cd $srcdir/"ia"
git submodule init
git submodule update
- cd rl_utils/src
- patch -uN rl_utils.cpp $srcdir/rl-utils-numeric-include.patch
}
build() {
cd $srcdir/"ia"
+ mkdir -p build && cd build
+ cmake ..
make
}
package() {
cd "ia"
#install licenses
- install -DTm644 "target/license.txt"\
+ install -DTm644 "build/res/license.txt"\
"${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- install -DTm644 "target/images/SPECIAL_ELITE_License.txt" \
+ install -DTm644 "build/res/images/SPECIAL_ELITE_License.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/SPECIAL_ELITE_License.txt"
#install docs
- install -DTm644 "target/contact.txt" \
+ install -DTm644 "build/res/contact.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/contact.txt"
- install -DTm644 "target/credits.txt" \
+ install -DTm644 "build/res/credits.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/credits.txt"
- install -DTm644 "target/manual.txt" \
+ install -DTm644 "build/res/manual.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/manual.txt"
- install -DTm644 "target/release_history.txt" \
+ install -DTm644 "build/res/release_history.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/release_history.txt"
#make dir for save game storage
mkdir -p "${pkgdir}/var/lib"
install -dm775 -g games "${pkgdir}/var/lib/${pkgname}"
install -dm775 -g games "${pkgdir}/var/lib/${pkgname}/data"
- #move target
+ #move res
mkdir -p "${pkgdir}/opt/${pkgname}/"
- cp -R target/* "${pkgdir}/opt/${pkgname}/"
+ cp -R build/res "${pkgdir}/opt/${pkgname}/"
+ # copy main binary
+ cp build/ia "${pkgdir}/opt/${pkgname}/"
#link savegame folder
rm -rf "${pkgdir}/opt/${pkgname}/data"
ln -s "/var/lib/${pkgname}/data" "${pkgdir}/opt/${pkgname}"
diff --git a/rl-utils-numeric-include.patch b/rl-utils-numeric-include.patch
deleted file mode 100644
index 0489cd073e38..000000000000
--- a/rl-utils-numeric-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- rl_utils.cpp.old 2016-07-15 20:52:28.946108667 -0700
-+++ rl_utils.cpp 2016-07-15 20:54:15.415983666 -0700
-@@ -4,6 +4,7 @@
- #include <vector>
- #include <cassert>
- #include <sstream>
-+#include <numeric>
-
- #include "mersenne_twister.hpp"
-
diff --git a/room-numeric-include.patch b/room-numeric-include.patch
deleted file mode 100644
index 597a84ce434f..000000000000
--- a/room-numeric-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- room.cpp.old 2016-07-15 20:51:40.885423667 -0700
-+++ room.cpp 2016-07-15 20:51:50.536913667 -0700
-@@ -2,6 +2,7 @@
-
- #include <algorithm>
- #include <climits>
-+#include <numeric>
-
- #include "init.hpp"
- #include "map.hpp"