summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzayatura2023-06-09 10:06:05 +0300
committerzayatura2023-06-09 10:06:05 +0300
commit7efc8b766653dbf8420978915157da000fa736e8 (patch)
tree7a323ac3a3e0d266efc11d9d46b750a25ef6e342
parent2cecc6a30556b392b23005c52edd8e81ea24ba15 (diff)
downloadaur-7efc8b766653dbf8420978915157da000fa736e8.tar.gz
Updated to v22 and to prebuilt binary
-rw-r--r--PKGBUILD76
-rw-r--r--infra-arcana.sh2
2 files changed, 35 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0908387e0964..4212088ab3c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-#Maintainer: paskali <paskali2005 at gmail dot com>
+#Maintainer: zayatura <zayatura@tutanota.com>
pkgname=infra-arcana
-pkgver=21.0.1
+pkgver=22.0.0
pkgrel=1
epoch=
pkgdesc="Roguelike game inspired by H.P. Lovecraft"
@@ -8,64 +8,56 @@ arch=('i686' 'x86_64')
url="https://sites.google.com/site/infraarcana/home"
license=('custom:Infra Arcana License')
groups=()
-makedepends=(cmake)
+makedepends=()
depends=('sdl2_image' 'sdl2_mixer' 'hicolor-icon-theme')
conflicts=('infra-arcana-git')
install=${pkgname}.install
-source=( "git+https://gitlab.com/martin-tornqvist/ia.git#tag=v""$pkgver"
- "${pkgname}.install"
- "${pkgname}.desktop"
- "${pkgname}.sh")
-md5sums=('SKIP'
- 'd82f8781f8d1ce1df8c53094ce5c3b27'
- '2e28c2803d7d2cd4376dcd3aa6512774'
- '87294b81f5a2f98a78d318a5dcec7caf')
-
-prepare(){
- cd $srcdir/ia
-}
-
-build() {
- cd $srcdir/"ia"
- mkdir -p build && cd build
- cmake ..
- make ia
-}
+source=("ia_linux_x64_v$pkgver.zip::https://gitlab.com/martin-tornqvist/ia/-/jobs/artifacts/v$pkgver/download?job=build-linux"
+ "icon_v$pkgver.ico::https://gitlab.com/martin-tornqvist/ia/-/raw/v$pkgver/icon/icon.ico?inline=false"
+ "${pkgname}.install"
+ "${pkgname}.desktop"
+ "${pkgname}.sh")
+sha256sums=('776a083044ad877f2c5fca5fcf73b92f286629df73dff6ae77720b3831c0148c'
+ '5c5b0b435e5effead5a700bc870aaf227536f32e736348f23956048d7c3225fd'
+ '3675cbaa28ce7e9e99271914f957cdbec942799aef0f88584cd99ddd642360d2'
+ 'c7738445681a33b5a1ca95528c0d3a6131bd867d6ce76f3b64677cee846a83c3'
+ 'fc7f7ab24e2e5adc8958842b27925ad97037b82fc8e722f4aaf14573f3308c82')
package() {
- cd "ia"
- #install licenses
- install -DTm644 "build/LICENSE.txt"\
+ cd $srcdir/ia_linux_x64_v$pkgver
+
+ #install licenses
+ install -DTm644 "./LICENSE.txt"\
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
- install -DTm644 "build/LICENSE-FONT-SPECIAL-ELITE.txt" \
+ install -DTm644 "./LICENSE-FONT-SPECIAL-ELITE.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-FONT-SPECIAL-ELITE.txt"
- install -DTm644 "build/LICENSE-AUDIO.txt"\
+ install -DTm644 "./LICENSE-AUDIO.txt"\
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-AUDIO.txt"
- install -DTm644 "build/LICENSE-FONT-DEJAVU.txt"\
+ install -DTm644 "./LICENSE-FONT-DEJAVU.txt"\
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-FONT-DEJAVU.txt"
- install -DTm644 "build/LICENSE-FONTS.txt"\
+ install -DTm644 "./LICENSE-FONTS.txt"\
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-FONTS.txt"
- #install docs
- install -DTm644 "build/contact.txt" \
+ #install docs
+ install -DTm644 "./contact.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/contact.txt"
- install -DTm644 "build/credits.txt" \
+ install -DTm644 "./credits.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/credits.txt"
- install -DTm644 "build/release_history.txt" \
+ install -DTm644 "./release_history.txt" \
"${pkgdir}/usr/share/doc/${pkgname}/release_history.txt"
- # copy data
+ # copy data
mkdir -p "${pkgdir}/opt/${pkgname}/"
- cp -R build/audio "${pkgdir}/opt/${pkgname}/"
- cp -R build/data "${pkgdir}/opt/${pkgname}/"
- cp -R build/gfx "${pkgdir}/opt/${pkgname}/"
- cp build/manual.txt "${pkgdir}/opt/${pkgname}/"
- # copy main binary
- cp build/ia "${pkgdir}/opt/${pkgname}/"
+ cp -R ./audio "${pkgdir}/opt/${pkgname}/"
+ cp -R ./data "${pkgdir}/opt/${pkgname}/"
+ cp -R ./gfx "${pkgdir}/opt/${pkgname}/"
+ cp ./manual.txt "${pkgdir}/opt/${pkgname}/"
+ # copy main binary
+ cp ./ia "${pkgdir}/opt/${pkgname}/"
# this shell script is required as the compiled binary relies on
# relative references
- install -Dm755 "../${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
#install icon
- install -Dm644 "icon/icon.ico" \
+ install -Dm644 "${srcdir}/icon_v$pkgver.ico" \
"$pkgdir/usr/share/icons/hicolor/128x128/apps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}.desktop" \
"$pkgdir/usr/share/applications/${pkgname}.desktop"
diff --git a/infra-arcana.sh b/infra-arcana.sh
index 9da1a1650708..9dc5959091cd 100644
--- a/infra-arcana.sh
+++ b/infra-arcana.sh
@@ -1,3 +1,3 @@
#!/usr/bin/sh
cd /opt/infra-arcana
-./ia
+exec ./ia