summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetamer2015-08-26 09:17:06 -0400
committermetamer2015-08-26 09:17:06 -0400
commitc7bb9c80ebe89ca8e26f7b8820a99749c830b4fa (patch)
tree65aaa568a8e05ab9f905526463e7b98a01b6a3fe
parent9e68eb3fbeeda9f16d508069f72d86144b749792 (diff)
downloadaur-c7bb9c80ebe89ca8e26f7b8820a99749c830b4fa.tar.gz
adjusted chmod to enable write on /opt/data
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d364c125df57..1bffa643a14f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: metamer <metamer at openmailbox dot org>
pkgname=infra-arcana
pkgver=17.0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Roguelike game inspired by H.P. Lovecraft"
arch=('i686' 'x86_64')
@@ -37,7 +37,8 @@ package() {
mkdir -p "${pkgdir}/opt/${pkgname}/"
cp -R target/* "${pkgdir}/opt/${pkgname}/"
- chmod a+w "${pkgdir}/opt/${pkgname}/data/save"
+ # required to allow users to write saved games and high scores to data
+ chmod -R a+w "${pkgdir}/opt/${pkgname}/data"
# this shell script is required as the compiled binary relies on relative references
install -Dm755 "../${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"