summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreomanis2018-08-17 00:58:05 +0200
committereomanis2018-08-17 00:58:05 +0200
commitcbdf16727fe320e8894d45f86bfee13a7c0cb5d5 (patch)
tree62d07d6770659c87a2ca296bfd2d6ab310aa2762
downloadaur-cbdf16727fe320e8894d45f86bfee13a7c0cb5d5.tar.gz
Initial commit, inherit-acl 0.1.0
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f428160be3b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = inherit-acl
+ pkgdesc = Tool that applies to a path its parent directory's permissions and ACL
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://eomanis.mooo.com/permshare/inherit-acl/index.xhtml
+ arch = any
+ license = GPL3
+ depends = bash>=4.3
+ depends = coreutils
+ depends = sed
+ depends = acl
+ optdepends = sudo: Sudo integration
+ source = http://eomanis.mooo.com/permshare/inherit-acl/inherit-acl-0.1.0.tar.gz
+ sha256sums = 8df51daec1129b9d683498b797465b41d1377adc26860381dc9820c2ba68970e
+
+pkgname = inherit-acl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..fbfa3fc50618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: eomanis at web dot de
+
+pkgname='inherit-acl'
+pkgverUpstream="0.1.0"
+pkgver="${pkgverUpstream//-/.}"
+pkgrel=1
+pkgdesc="Tool that applies to a path its parent directory's permissions and ACL"
+arch=('any')
+url='http://eomanis.mooo.com/permshare/inherit-acl/index.xhtml'
+license=('GPL3')
+depends=('bash>=4.3' 'coreutils' 'sed' 'acl')
+optdepends=('sudo: Sudo integration')
+source=("http://eomanis.mooo.com/permshare/inherit-acl/inherit-acl-${pkgverUpstream}.tar.gz")
+sha256sums=('8df51daec1129b9d683498b797465b41d1377adc26860381dc9820c2ba68970e')
+
+package() {
+
+ # Place the main bash scripts into /usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ cp -t . "${srcdir}/inherit-acl"
+ chmod u=rwx,go=rx "inherit-acl"
+ cp -t . "${srcdir}/inherit-acl-run"
+ chmod u=rwx,go=rx "inherit-acl-run"
+}