aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK2020-04-18 19:30:23 +0200
committerTBK2020-04-18 19:30:30 +0200
commitf85013fc76afb89c6b49f3f5e627cab8cc0b22f0 (patch)
treec3a668e963ca0616da001a3e75229d93ddf42085
downloadaur-initify.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
-rw-r--r--README.md17
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd6051820854
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = initify
+ pkgdesc = Convert systemd services to OpenRC init-scripts.
+ pkgver = r12.f9ccbb1
+ pkgrel = 1
+ url = https://github.com/goose121/initify
+ arch = any
+ license = MIT
+ depends = perl
+ source = initify::git+https://github.com/goose121/initify.git
+ sha512sums = SKIP
+
+pkgname = initify
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..706df8c3a5ea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/*
+src/*
+*.pkg.tar.xz
+*.tar.gz
+initify/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad3c920c4ed8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: TBK <aur at jjtc dot eu>
+# Contributor: TBK <aur at jjtc dot eu>
+
+pkgname=initify
+pkgver=r12.f9ccbb1
+pkgrel=1
+pkgdesc='Convert systemd services to OpenRC init-scripts.'
+url='https://github.com/goose121/initify'
+arch=('any')
+license=('MIT')
+depends=('perl')
+source=("$pkgname::git+https://github.com/goose121/initify.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 initify.pl "$pkgdir"/usr/bin/initify
+ install -Dm755 cronify.pl "$pkgdir"/usr/bin/cronify
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..a0b9e1a56155
--- /dev/null
+++ b/README.md
@@ -0,0 +1,17 @@
+# initify
+ Arch User Repository initify
+
+## Update package
+
+* Update package version in PKGBUILD
+* Generate new checksums with
+
+```$ updpkgsums```
+
+* Test install
+
+```$ makepkg -si```
+
+* Update .SRCINFO
+
+```$ makepkg --printsrcinfo > .SRCINFO```