summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYorick Peterse2020-10-04 14:28:25 +0200
committerYorick Peterse2020-10-04 14:29:50 +0200
commitec37694361f8539a1cb7d976891d50aa0c7c3868 (patch)
treec65f8e5bd59925bd091f063fdb216a2fde105cdc
downloadaur-ec37694361f8539a1cb7d976891d50aa0c7c3868.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0f1a4b7f980
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = inko
+ pkgdesc = A statically-typed object-oriented language for writing concurrent programs
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://inko-lang.org
+ arch = x86_64
+ license = MPL2
+ makedepends = coreutils
+ makedepends = clang
+ makedepends = rust>=1.34
+ makedepends = make
+ depends = ruby>=2.3.0
+ depends = libffi>=3.2.0
+ provides = inko
+ conflicts = inko-git
+ options = strip
+ options = !docs
+ options = !libtool
+ options = !staticlibs
+ source = https://releases.inko-lang.org/0.8.0.tar.gz
+ sha256sums = 429d5ace7f6eb463cc53006ea32482f760e79dd34d1f5a51dceb9fcdb0cf7b07
+
+pkgname = inko
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..90d596482ab6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..611b2fe152c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yorick Peterse <aur AT yorickpeterse DOT com>
+
+pkgname=inko
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="A statically-typed object-oriented language for writing concurrent programs"
+url="https://inko-lang.org"
+license=(MPL2)
+arch=(x86_64)
+depends=('ruby>=2.3.0' 'libffi>=3.2.0')
+makedepends=(coreutils clang 'rust>=1.34' make)
+provides=(inko)
+conflicts=(inko-git)
+options=(strip !docs !libtool !staticlibs)
+source=('inko::git+https://gitlab.com/inko-lang/inko.git')
+source=('https://releases.inko-lang.org/0.8.0.tar.gz')
+sha256sums=('429d5ace7f6eb463cc53006ea32482f760e79dd34d1f5a51dceb9fcdb0cf7b07')
+
+build() {
+ # Enable the libffi-system feature so the system libffy is used, instead of
+ # compiling it from source.
+ make build FEATURES='libinko/libffi-system'
+}
+
+package() {
+ make install DESTDIR="${pkgdir}" PREFIX='/usr'
+}