summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYorick Peterse2020-10-01 22:18:47 +0200
committerYorick Peterse2020-10-01 22:18:47 +0200
commit25ec10e5a4da61523c18aa77ec618b545d3b3ad8 (patch)
tree71b361ec18ca5c9d4f4b44756a4f45c35cf183cf
downloadaur-25ec10e5a4da61523c18aa77ec618b545d3b3ad8.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..864d4465a7c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = inko-git
+ pkgdesc = A statically-typed object-oriented language for writing concurrent programs
+ pkgver = 0.7.0.r25.g5f9bf6e0
+ pkgrel = 1
+ url = https://inko-lang.org
+ arch = x86_64
+ license = MPL2
+ makedepends = coreutils
+ makedepends = clang
+ makedepends = rust>=1.34
+ makedepends = make
+ depends = ruby>=2.3.0
+ depends = libffi>=3.2.0
+ provides = inko
+ conflicts = inko
+ conflicts = inko-bin
+ options = strip
+ options = !docs
+ options = !libtool
+ options = !staticlibs
+ source = inko::git+https://gitlab.com/inko-lang/inko.git
+ sha256sums = SKIP
+
+pkgname = inko-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..90d596482ab6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72bb50135b23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Yorick Peterse <aur AT yorickpeterse DOT com>
+
+pkgname=inko-git
+pkgver=0.7.0.r25.g5f9bf6e0
+pkgrel=1
+pkgdesc="A statically-typed object-oriented language for writing concurrent programs"
+url="https://inko-lang.org"
+license=(MPL2)
+arch=(x86_64)
+depends=('ruby>=2.3.0' 'libffi>=3.2.0')
+makedepends=(coreutils clang 'rust>=1.34' make)
+provides=(inko)
+conflicts=(inko inko-bin)
+options=(strip !docs !libtool !staticlibs)
+source=('inko::git+https://gitlab.com/inko-lang/inko.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd inko
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd inko
+
+ # Enable the libffi-system feature so the system libffy is used, instead of
+ # compiling it from source.
+ make build FEATURES='libinko/libffi-system'
+}
+
+package() {
+ cd inko
+ make install DESTDIR="${pkgdir}" PREFIX='/usr'
+}