summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-07-16 16:23:40 +0200
committerhaawda2017-07-16 16:23:40 +0200
commit3f32c51974c6cbbb0099079ec31bec8b90cd91e9 (patch)
tree19d673d82329621287afbee5772b833c8fde5784
parent9bc0d28ede01b42f069e71b26b2beaddbb0ac392 (diff)
downloadaur-3f32c51974c6cbbb0099079ec31bec8b90cd91e9.tar.gz
remove patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--inkscape-0.92.1-gcc7-1.patch77
3 files changed, 5 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e9b9cd33c3a..a56a637c8d2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 10 20:09:10 UTC 2017
+# Sun Jul 16 14:23:13 UTC 2017
pkgbase = inkscape-092-git
pkgdesc = An Open Source vector graphics editor, using Scalable Vector Graphics (SVG) file format, from git branch 0.92.x
- pkgver = 20170607
+ pkgver = 20170715
pkgrel = 1
url = https://gitlab.com/inkscape/inkscape
arch = i686
@@ -41,9 +41,7 @@ pkgbase = inkscape-092-git
options = !libtool
options = !makeflags
source = inkscape.git::git+https://gitlab.com/inkscape/inkscape#branch=0.92.x
- source = inkscape-0.92.1-gcc7-1.patch
md5sums = SKIP
- md5sums = a6b01372fa4a1882e72d6018beb55730
pkgname = inkscape-092-git
diff --git a/PKGBUILD b/PKGBUILD
index 7eee663df010..07cd353153f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=inkscape-092-git
-pkgver=20170607
+pkgver=20170715
pkgrel=1
pkgdesc="An Open Source vector graphics editor, using Scalable Vector Graphics (SVG) file format, from git branch 0.92.x"
url="https://gitlab.com/inkscape/inkscape"
@@ -19,9 +19,8 @@ makedepends=('boost' 'intltool' 'git' 'gettext' 'pango' 'fontconfig' 'python' 'c
provides=('inkscape')
conflicts=('inkscape')
options=('!libtool' '!makeflags')
-source=('inkscape.git::git+https://gitlab.com/inkscape/inkscape#branch=0.92.x' inkscape-0.92.1-gcc7-1.patch)
-md5sums=('SKIP'
- 'a6b01372fa4a1882e72d6018beb55730')
+source=('inkscape.git::git+https://gitlab.com/inkscape/inkscape#branch=0.92.x')
+md5sums=('SKIP')
_gitname="inkscape.git"
pkgver() {
@@ -40,7 +39,6 @@ prepare() {
sed -i '1s|/usr/bin/env python\>|/usr/bin/env python2|g' share/extensions/ink2canvas/svg.py
sed -i '1s|/usr/bin/env python\>|/usr/bin/env python2|g' share/extensions/ink2canvas/canvas.py
sed -i '1s|/usr/bin/env python3\>|/usr/bin/env python2|g' CMakeScripts/cmake_consistency_check.py
- patch -Np1 < "$srcdir"/inkscape-0.92.1-gcc7-1.patch || true
}
build() {
diff --git a/inkscape-0.92.1-gcc7-1.patch b/inkscape-0.92.1-gcc7-1.patch
deleted file mode 100644
index 455727d00229..000000000000
--- a/inkscape-0.92.1-gcc7-1.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- inkscape-0.92.1/src/ui/tools/flood-tool.cpp.orig 2017-05-16 20:45:31.374672304 +0100
-+++ inkscape-0.92.1/src/ui/tools/flood-tool.cpp 2017-05-16 21:35:01.564359096 +0100
-@@ -196,6 +196,21 @@
- }
-
- /**
-+ * \brief Check whether two unsigned integers are close to each other
-+ *
-+ * \param[in] a The 1st unsigned int
-+ * \param[in] b The 2nd unsigned int
-+ * \param[in] d The threshold for comparison
-+ *
-+ * \return true if |a-b| <= d; false otherwise
-+ */
-+static bool compare_guint32(guint32 const a, guint32 const b, guint32 const d)
-+{
-+ const int difference = std::abs(static_cast<int>(a) - static_cast<int>(b));
-+ return difference <= d;
-+}
-+
-+/**
- * Compare a pixel in a pixel buffer with another pixel to determine if a point should be included in the fill operation.
- * @param check The pixel in the pixel buffer to check.
- * @param orig The original selected pixel to use as the fill target color.
-@@ -232,27 +247,35 @@
-
- switch (method) {
- case FLOOD_CHANNELS_ALPHA:
-- return abs(static_cast<int>(ac) - ao) <= threshold;
-+ return compare_guint32(ac, ao, threshold);
- case FLOOD_CHANNELS_R:
-- return abs(static_cast<int>(ac ? unpremul_alpha(rc, ac) : 0) - (ao ? unpremul_alpha(ro, ao) : 0)) <= threshold;
-+ return compare_guint32(ac ? unpremul_alpha(rc, ac) : 0,
-+ ao ? unpremul_alpha(ro, ao) : 0,
-+ threshold);
- case FLOOD_CHANNELS_G:
-- return abs(static_cast<int>(ac ? unpremul_alpha(gc, ac) : 0) - (ao ? unpremul_alpha(go, ao) : 0)) <= threshold;
-+ return compare_guint32(ac ? unpremul_alpha(gc, ac) : 0,
-+ ao ? unpremul_alpha(go, ao) : 0,
-+ threshold);
- case FLOOD_CHANNELS_B:
-- return abs(static_cast<int>(ac ? unpremul_alpha(bc, ac) : 0) - (ao ? unpremul_alpha(bo, ao) : 0)) <= threshold;
-+ return compare_guint32(ac ? unpremul_alpha(bc, ac) : 0,
-+ ao ? unpremul_alpha(bo, ao) : 0,
-+ threshold);
- case FLOOD_CHANNELS_RGB:
-- guint32 amc, rmc, bmc, gmc;
-- //amc = 255*255 - (255-ac)*(255-ad); amc = (amc + 127) / 255;
-- //amc = (255-ac)*ad + 255*ac; amc = (amc + 127) / 255;
-- amc = 255; // Why are we looking at desktop? Cairo version ignores destop alpha
-- rmc = (255-ac)*rd + 255*rc; rmc = (rmc + 127) / 255;
-- gmc = (255-ac)*gd + 255*gc; gmc = (gmc + 127) / 255;
-- bmc = (255-ac)*bd + 255*bc; bmc = (bmc + 127) / 255;
--
-- diff += abs(static_cast<int>(amc ? unpremul_alpha(rmc, amc) : 0) - (amop ? unpremul_alpha(rmop, amop) : 0));
-- diff += abs(static_cast<int>(amc ? unpremul_alpha(gmc, amc) : 0) - (amop ? unpremul_alpha(gmop, amop) : 0));
-- diff += abs(static_cast<int>(amc ? unpremul_alpha(bmc, amc) : 0) - (amop ? unpremul_alpha(bmop, amop) : 0));
-- return ((diff / 3) <= ((threshold * 3) / 4));
--
-+ {
-+ guint32 amc, rmc, bmc, gmc;
-+ //amc = 255*255 - (255-ac)*(255-ad); amc = (amc + 127) / 255;
-+ //amc = (255-ac)*ad + 255*ac; amc = (amc + 127) / 255;
-+ amc = 255; // Why are we looking at desktop? Cairo version ignores destop alpha
-+ rmc = (255-ac)*rd + 255*rc; rmc = (rmc + 127) / 255;
-+ gmc = (255-ac)*gd + 255*gc; gmc = (gmc + 127) / 255;
-+ bmc = (255-ac)*bd + 255*bc; bmc = (bmc + 127) / 255;
-+
-+ int diff = 0; // The total difference between each of the 3 color components
-+ diff += std::abs(static_cast<int>(amc ? unpremul_alpha(rmc, amc) : 0) - static_cast<int>(amop ? unpremul_alpha(rmop, amop) : 0));
-+ diff += std::abs(static_cast<int>(amc ? unpremul_alpha(gmc, amc) : 0) - static_cast<int>(amop ? unpremul_alpha(gmop, amop) : 0));
-+ diff += std::abs(static_cast<int>(amc ? unpremul_alpha(bmc, amc) : 0) - static_cast<int>(amop ? unpremul_alpha(bmop, amop) : 0));
-+ return ((diff / 3) <= ((threshold * 3) / 4));
-+ }
- case FLOOD_CHANNELS_H:
- return ((int)(fabs(hsl_check[0] - hsl_orig[0]) * 100.0) <= threshold);
- case FLOOD_CHANNELS_S: