summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorExcitable Snowball2022-02-06 22:32:00 +0000
committerExcitable Snowball2022-02-06 22:32:00 +0000
commit30218d8e012dfb05761612cab2781d503a4442b0 (patch)
tree6c18d7b37aad569c031e1c1b5c0a228842c8259a
downloadaur-30218d8e012dfb05761612cab2781d503a4442b0.tar.gz
1.1.2
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
-rwxr-xr-xinkscape.sh2
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a344eb0c4ff0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = inkscape-appimage
+ pkgdesc = Professional vector graphics editor (official AppImage release)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://inkscape.org/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ provides = inkscape
+ conflicts = inkscape
+ noextract = freecad-1.1.2.AppImage
+ options = !strip
+ source = inkscape-1.1.2.AppImage::https://inkscape.org/gallery/item/31669/Inkscape-0a00cf5-x86_64.AppImage
+ source = inkscape.sh
+ sha256sums = b7a99b6c0ee2817706e77803643f4a6caf9e35bdec928e963c1d2ae86e5e4beb
+ sha256sums = 52214003ba59053e0faa2030d48b03c16bf540babd40ff7360928cd0145aa5de
+
+pkgname = inkscape-appimage
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..949562a68702
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.*
+src/
+pkg/
+*.AppImage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a7ac46a19e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Excitable Snowball <excitablesnowball@gmail.com>
+pkgname=inkscape-appimage
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Professional vector graphics editor (official AppImage release)"
+arch=('x86_64')
+url="https://inkscape.org/"
+license=('GPL' 'LGPL')
+depends=()
+provides=('inkscape')
+conflicts=('inkscape')
+options=('!strip')
+source=("inkscape-$pkgver.AppImage::https://inkscape.org/gallery/item/31669/Inkscape-0a00cf5-x86_64.AppImage"
+ "inkscape.sh")
+sha256sums=('b7a99b6c0ee2817706e77803643f4a6caf9e35bdec928e963c1d2ae86e5e4beb'
+ '52214003ba59053e0faa2030d48b03c16bf540babd40ff7360928cd0145aa5de')
+
+prepare() {
+ cd "${srcdir}"
+ chmod +x inkscape-${pkgver}.AppImage
+ ./inkscape-${pkgver}.AppImage --appimage-extract org.inkscape.Inkscape.desktop
+ ./inkscape-${pkgver}.AppImage --appimage-extract usr/share/icons/hicolor
+}
+
+package() {
+ install -Dm755 "${srcdir}/inkscape-${pkgver}.AppImage" "${pkgdir}/opt/appimages/inkscape.AppImage"
+ install -Dm755 "${srcdir}/inkscape.sh" "${pkgdir}/usr/bin/inkscape"
+ install -dm755 "${pkgdir}/usr/share"
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -m644 "${srcdir}/squashfs-root/org.inkscape.Inkscape.desktop" "${pkgdir}/usr/share/applications/org.inkscape.Inkscape.desktop"
+ cp -r --no-preserve=mode,ownership "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+}
diff --git a/inkscape.sh b/inkscape.sh
new file mode 100755
index 000000000000..68712abf0bc5
--- /dev/null
+++ b/inkscape.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/appimages/inkscape.AppImage "$@"