summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2017-08-26 12:03:11 +0300
committerJonian Guveli2017-08-26 12:03:11 +0300
commitd0e5a9098426f0ec8358fcde7e956af13c068d5c (patch)
tree7114c7325b29e01e1a1e0f4f915ef96ccb71109c
downloadaur-d0e5a9098426f0ec8358fcde7e956af13c068d5c.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4b1b3d64e8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Aug 26 09:02:56 UTC 2017
+pkgbase = inkscape-download-palette
+ pkgdesc = Inkscape extension to download color palettes
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/olibia/inkscape-download-palette
+ arch = any
+ license = GPL
+ depends = inkscape
+ depends = python2-lxml
+ provides = inkscape-download-palette
+ conflicts = inkscape-download-palette-git
+ source = inkscape-download-palette::https://github.com/olibia/inkscape-download-palette/archive/v1.0.tar.gz
+ md5sums = cd15f23883b2407cdd33d13f0e221036
+
+pkgname = inkscape-download-palette
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0cea8cd2350
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=inkscape-download-palette
+pkgver=1.0
+pkgrel=1
+pkgdesc="Inkscape extension to download color palettes"
+arch=("any")
+url="https://github.com/olibia/inkscape-download-palette"
+license=("GPL")
+depends=("inkscape" "python2-lxml")
+provides=("inkscape-download-palette")
+conflicts=("inkscape-download-palette-git")
+source=("$pkgname::https://github.com/olibia/inkscape-download-palette/archive/v$pkgver.tar.gz")
+md5sums=("cd15f23883b2407cdd33d13f0e221036")
+
+package() {
+ mkdir -p "$pkgdir/usr/share/inkscape/extensions/"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ cp "download_palette.inx" "$pkgdir/usr/share/inkscape/extensions/"
+ cp "download_palette.py" "$pkgdir/usr/share/inkscape/extensions/"
+}