summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-10-24 14:06:20 +0200
committerClaudia Pellegrino2022-10-24 14:06:20 +0200
commitb8a6c24ce19f5a56a829e46d6a67f4d3ec129dab (patch)
tree328880b1fb83d6b43459e9845cf106590b916e03
downloadaur-b8a6c24ce19f5a56a829e46d6a67f4d3ec129dab.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD84
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d891845178a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = inkscape-eggbot-git
+ pkgdesc = EggBot software as an Inkscape extension. Useful for other plotters, too.
+ pkgver = r673.e43aa82
+ pkgrel = 1
+ url = https://github.com/evil-mad/EggBot
+ arch = any
+ license = GPL2
+ license = GPL3
+ makedepends = git
+ makedepends = python
+ depends = inkscape
+ depends = python-ink-extensions-git
+ depends = python-plotink
+ provides = inkscape-eggbot
+ conflicts = inkscape-eggbot
+ options = !strip
+ source = inkscape-eggbot-git::git+https://github.com/evil-mad/EggBot.git
+ source = axidraw-3.6.0.tar.gz::https://github.com/evil-mad/axidraw/archive/v3.6.0.tar.gz
+ sha512sums = SKIP
+ sha512sums = 16f1c625598e95cf8ab096a3b54115d173e77c945b4b6a1d59620d21c04ecc9f424ff6db7aa47ddc7e06eec685635b179ca7aaa66d6dab24fd6a26ce8b9f4eff
+
+pkgname = inkscape-eggbot-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..675af667d427
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/.vscode/
+/inkscape-eggbot-git/
+/src/
+/pkg/
+*.log
+*.pkg.*
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b40203eb9b91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=inkscape-eggbot-git
+_gitpkgname=EggBot
+pkgver=r673.e43aa82
+_axidraw_pkgver=3.6.0
+pkgrel=1
+pkgdesc='EggBot software as an Inkscape extension. Useful for other plotters, too.'
+arch=('any')
+url='https://github.com/evil-mad/EggBot'
+license=(
+ 'GPL2' # vendored `axidrawinternal` dependency
+ 'GPL3' # EggBot extension proper
+)
+depends=('inkscape' 'python-ink-extensions-git' 'python-plotink')
+makedepends=('git' 'python')
+provides=('inkscape-eggbot')
+conflicts=('inkscape-eggbot')
+options=('!strip')
+
+source=(
+ "${pkgname}::git+https://github.com/evil-mad/EggBot.git"
+ "axidraw-${_axidraw_pkgver}.tar.gz::https://github.com/evil-mad/axidraw/archive/v${_axidraw_pkgver}.tar.gz"
+)
+
+sha512sums=(
+ 'SKIP'
+ '16f1c625598e95cf8ab096a3b54115d173e77c945b4b6a1d59620d21c04ecc9f424ff6db7aa47ddc7e06eec685635b179ca7aaa66d6dab24fd6a26ce8b9f4eff'
+)
+
+pkgver() {
+ printf "r%s.%s" \
+ "$(git -C "${pkgname}" rev-list --count HEAD)" \
+ "$(git -C "${pkgname}" rev-parse --short HEAD)"
+}
+
+package() {
+ local _site_packages
+
+ echo >&2 'Packaging the Inkscape extension'
+ mkdir -p "${pkgdir}/usr/share/inkscape/extensions"
+ cp -r --preserve=mode -T \
+ "${srcdir}/${pkgname}/inkscape_driver" \
+ "${pkgdir}/usr/share/inkscape/extensions/${_gitpkgname}"
+
+ echo >&2 'Packaging vendored runtime dependency: axidrawinternal'
+ mkdir -p "${pkgdir}/usr/share/inkscape/extensions/${_gitpkgname}/axidraw_deps"
+ cp -r --preserve=mode -T \
+ "${srcdir}/axidraw-${_axidraw_pkgver}/inkscape driver" \
+ "${pkgdir}/usr/share/inkscape/extensions/${_gitpkgname}/axidrawinternal"
+
+ echo >&2 'Symlinking other runtime dependencies'
+ _site_packages="$(
+ python -c 'import site; print(site.getsitepackages()[0])'
+ )"
+ echo >&2 "Detected site-packages dir: ${_site_packages}"
+ ln -ns \
+ "${_site_packages}/plotink" \
+ "${_site_packages}/ink_extensions" \
+ "${_site_packages}/ink_extensions_utils" \
+ "${pkgdir}/usr/share/inkscape/extensions/${_gitpkgname}/axidraw_deps"
+
+ echo >&2 'Adding stub for runtime dependencies'
+ # See also: /usr/share/inkscape/extensions/plotink/plot_utils_import.py
+ echo 'from plotink.plot_utils_import import *' \
+ > "${pkgdir}/usr/share/inkscape/extensions/${_gitpkgname}/plot_utils_import.py"
+
+ echo >&2 'Packaging examples'
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -r --preserve=mode -T \
+ "${srcdir}/${pkgname}/example files" \
+ "${pkgdir}/usr/share/${pkgname}/examples"
+
+ echo >&2 'Packaging the documentation'
+ install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ "${srcdir}/${pkgname}/README.md"
+ cp -r --preserve=mode -T \
+ "${srcdir}/${pkgname}/docs" \
+ "${pkgdir}/usr/share/doc/${pkgname}/html"
+
+ echo >&2 'Packaging the license'
+ install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \
+ "${srcdir}/${pkgname}/LICENSE"
+}