summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-01-31 21:44:04 +0100
committerhaawda2018-01-31 21:44:04 +0100
commit7de2a5177c1c359e4c20db00b3ac123fa524ec87 (patch)
treed8d5e991e33ff44514fcf70049391b3306078d21
parent203e04f99951a2ca2cade84c623095c8107c172a (diff)
downloadaur-7de2a5177c1c359e4c20db00b3ac123fa524ec87.tar.gz
detect imagemagick6
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd9e3c81696e..e986f4e699a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = inkscape-git
pkgdesc = An Open Source vector graphics editor, using SVG file format, from git master
- pkgver = 20180130.20096
+ pkgver = 20180131.20102
pkgrel = 1
url = https://launchpad.net/inkscape
arch = i686
@@ -36,6 +36,7 @@ pkgbase = inkscape-git
optdepends = python2-lxml: some extensions and filters
optdepends = uniconvertor: reading/writing to some proprietary formats
optdepends = ruby: for simplepath extension
+ optdepends = imagemagick6: for some file conversions
provides = inkscape
conflicts = inkscape
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index 085746317573..fd61e323782a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=inkscape-git
-pkgver=20180130.20096
+pkgver=20180131.20102
pkgrel=1
pkgdesc="An Open Source vector graphics editor, using SVG file format, from git master"
url="https://launchpad.net/inkscape"
@@ -14,7 +14,8 @@ depends=('aspell' 'gc' 'poppler-glib' 'libxslt' 'gsl' 'libyaml' 'potrace' 'gdl>=
optdepends=('python2-numpy: some extensions'
'python2-lxml: some extensions and filters'
'uniconvertor: reading/writing to some proprietary formats'
- 'ruby: for simplepath extension')
+ 'ruby: for simplepath extension'
+ 'imagemagick6: for some file conversions')
makedepends=('cmake' 'boost' 'intltool' 'git' 'gettext' 'pango' 'python' 'fontconfig')
provides=('inkscape')
conflicts=('inkscape')
@@ -38,14 +39,14 @@ prepare() {
sed -i 's|/usr/bin/env python\>|/usr/bin/env python2|g' share/*/{test/,}*.py
sed -i 's|"python" },|"python2" },|g' src/extension/implementation/script.cpp
sed -i 's|"python"|"python2"|g' src/main.cpp
- patch -Np1 < "$srcdir"/document-interface.patch
+ patch -Np1 < "$srcdir"/document-interface.patch || true
}
build() {
cd "$_gitname"
[[ -d build ]] || mkdir build
cd build
-
+ export PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RELEASE \
@@ -57,5 +58,4 @@ build() {
package() {
cd "$_gitname/build"
make DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/share/icons/hicolor/icon-theme.cache
}