summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-06-01 22:31:34 +0200
committerhaawda2019-06-01 22:31:34 +0200
commitcbd9955b817fcad2c0e3257d8fef23154af7bcaf (patch)
treeebb1c7902bce69278ef4467042793d209d276db2
parenta3d9846da03982ef822e28712cf2e28ebe915465 (diff)
downloadaur-cbd9955b817fcad2c0e3257d8fef23154af7bcaf.tar.gz
add prepare function for git submodule
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c027514eb9f..8074d7c4f077 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = inkscape-git
pkgdesc = An Open Source vector graphics editor, using SVG file format, from git master
- pkgver = 1.0+devel.r4386.g0a5dc27633
+ pkgver = 1.0+devel.r4525.ge00088acae
pkgrel = 1
epoch = 1
url = https://gitlab.com/inkscape/inkscape
@@ -32,6 +32,7 @@ pkgbase = inkscape-git
depends = gtkspell3
depends = libsm
depends = libmagick6
+ depends = libsoup
optdepends = python-numpy: some extensions
optdepends = python-lxml: some extensions and filters
optdepends = uniconvertor: reading/writing to some proprietary formats
@@ -41,7 +42,7 @@ pkgbase = inkscape-git
conflicts = inkscape
options = !libtool
options = !buildflags
- source = inkscape.git::git+https://gitlab.com/inkscape/inkscape
+ source = inkscape.git::git+https://gitlab.com/inkscape/inkscape.git
sha1sums = SKIP
pkgname = inkscape-git
diff --git a/PKGBUILD b/PKGBUILD
index f35a47f3a2c1..1dc710a3be49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Contributor: Splex
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Co-Maintainer: bartus <arch-user-repo@bartus.33mail.com>
pkgname=inkscape-git
-pkgver=1.0+devel.r4386.g0a5dc27633
+pkgver=1.0+devel.r4525.ge00088acae
pkgrel=1
epoch=1
pkgdesc="An Open Source vector graphics editor, using SVG file format, from git master"
@@ -11,7 +12,7 @@ arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
depends=('double-conversion' 'gc' 'poppler-glib' 'libxslt' 'gsl' 'libyaml' 'potrace' 'gdl>=3.8.0.25'
'gtkmm3' 'libcdr' 'libvisio' 'dbus-glib' 'jemalloc' 'gtkspell3' 'libsm'
- 'libmagick6')
+ 'libmagick6' 'libsoup')
optdepends=('python-numpy: some extensions'
'python-lxml: some extensions and filters'
'uniconvertor: reading/writing to some proprietary formats'
@@ -21,7 +22,7 @@ makedepends=('cmake' 'boost' 'intltool' 'git' 'gettext' 'pango' 'python' 'fontco
provides=('inkscape')
conflicts=('inkscape')
options=('!libtool' '!buildflags')
-source=("inkscape.git::git+$url")
+source=("inkscape.git::git+$url.git")
sha1sums=('SKIP')
_gitname="inkscape.git"
@@ -30,12 +31,10 @@ pkgver() {
printf %s.%s+devel.r%s.g%s $(grep -oP -e "INKSCAPE_VERSION_(MAJOR|MINOR) +\K[0-9]+" CMakeLists.txt) $(git rev-list $(git describe --tag --abbrev=0)..HEAD --count) $(git log --pretty=format:'%h' -n 1)
}
-#prepare() {
-# cd "$_gitname"
-# find share -type f -name "*.py" -exec \
-# sed -i '1s|/usr/bin/env python\>|/usr/bin/env python2|g' {} \;
-# sed -i 's|"python" },|"python2" },|g' src/extension/implementation/script.cpp
-#}
+prepare() {
+ cd "$_gitname"
+ git submodule update --init --recursive
+}
build() {
cd "$_gitname"
@@ -44,8 +43,7 @@ build() {
export PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=RELEASE \
- -DWITH_DBUS=OFF
+ -DCMAKE_BUILD_TYPE=RELEASE
make
}