summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-11-06 07:43:43 +0100
committerhaawda2018-11-06 07:43:43 +0100
commitfd0748f700c0db83b7b0f5615dd289caa5969c15 (patch)
treef40fc68f40d605d0c0b3edd341d413bb12a3a600
parent6e1faffb64ef7ded6250542f0981fca9a08231fd (diff)
downloadaur-fd0748f700c0db83b7b0f5615dd289caa5969c15.tar.gz
add a fix for poppler 0.71.0
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be7e82f822b5..147683b70fec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,6 +37,7 @@ prepare() {
sed -i '1s|/usr/bin/env python3\>|/usr/bin/env python2|g' CMakeScripts/cmake_consistency_check.py
sed -i 's|"python" },|"python2" },|g' src/extension/implementation/script.cpp
sed -i 's|"python"|"python2"|g' src/main.cpp
+ sed -i -e 's|GBool|bool|g' -e 's|gTrue|true|g' -e 's|gFalse|false|g' src/extension/internal/pdfinput/pdf-parser.{h,cpp}
}
build() {
@@ -52,6 +53,6 @@ build() {
}
package() {
- cd "$_gitname/build"
+ cd "$_gitname"/build
make DESTDIR="$pkgdir" install
}