summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2017-10-27 14:26:06 +0300
committerJonian Guveli2017-10-27 14:26:06 +0300
commit0ee708ae8f9415f557c47721f8cfb7ed7a2b1ba2 (patch)
treef28dc759b2bb6e8e1fbfd4017bd0152bc40035fb
downloadaur-0ee708ae8f9415f557c47721f8cfb7ed7a2b1ba2.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29d06b999972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Oct 27 11:25:51 UTC 2017
+pkgbase = inkscape-multipage-export
+ pkgdesc = Inkscape extension to generate color palettes
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/olibia/inkscape-multipage-export
+ arch = any
+ license = GPL
+ depends = inkscape
+ depends = python2-lxml
+ provides = inkscape-multipage-export
+ conflicts = inkscape-multipage-export-git
+ source = inkscape-multipage-export::https://github.com/olibia/inkscape-multipage-export/archive/v1.0.tar.gz
+ md5sums = 90be17defa5cdf7981788c5893c54694
+
+pkgname = inkscape-multipage-export
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f59140d837d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=inkscape-multipage-export
+pkgver=1.0
+pkgrel=1
+pkgdesc="Inkscape extension to generate color palettes"
+arch=("any")
+url="https://github.com/olibia/inkscape-multipage-export"
+license=("GPL")
+depends=("inkscape" "python2-lxml")
+provides=("inkscape-multipage-export")
+conflicts=("inkscape-multipage-export-git")
+source=("$pkgname::https://github.com/olibia/inkscape-multipage-export/archive/v$pkgver.tar.gz")
+md5sums=("90be17defa5cdf7981788c5893c54694")
+
+package() {
+ mkdir -p "$pkgdir/usr/share/inkscape/extensions/"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ cp "multipage_export.inx" "$pkgdir/usr/share/inkscape/extensions/"
+ cp "multipage_export.py" "$pkgdir/usr/share/inkscape/extensions/"
+}