summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2023-03-04 16:23:14 +0100
committerClaudia Pellegrino2023-03-04 16:23:14 +0100
commit1abeb0a3cec3a79c85743896b84c577d218ed244 (patch)
treebe59ea2ecf612b2359bdf5a0b356cf9cbd98e3ab
downloadaur-1abeb0a3cec3a79c85743896b84c577d218ed244.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD40
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef3f91932769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = inkscape-openpaths-git
+ pkgdesc = Inkscape extension for opening up closed paths, e. g. for single-line fonts in OPF/OTF/TTF format
+ pkgver = r8.10d0d7c
+ pkgrel = 1
+ url = https://gitlab.com/EllenWasbo/inkscape-extension-openpaths
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = inkscape
+ options = !strip
+ source = inkscape-openpaths-git::git+https://gitlab.com/EllenWasbo/inkscape-extension-openpaths.git
+ sha512sums = SKIP
+
+pkgname = inkscape-openpaths-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a6337ba6b8f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/.vscode/
+/inkscape-openpaths-git/
+/src/
+/pkg/
+*.log
+*.pkg.*
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28a4f5c56783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=inkscape-openpaths-git
+pkgver=r8.10d0d7c
+pkgrel=1
+pkgdesc='Inkscape extension for opening up closed paths, e. g. for single-line fonts in OPF/OTF/TTF format'
+arch=('any')
+url='https://gitlab.com/EllenWasbo/inkscape-extension-openpaths'
+
+# No license file present but the author has granted the GPL2 license here:
+# https://inkscape.org/~EllenWasbo/%E2%98%85openclosedpath
+license=('GPL2')
+
+depends=('inkscape')
+makedepends=('git')
+options=('!strip')
+
+source=(
+ "${pkgname}::git+https://gitlab.com/EllenWasbo/inkscape-extension-openpaths.git"
+)
+
+sha512sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ printf "r%s.%s" \
+ "$(git -C "${pkgname}" rev-list --count HEAD)" \
+ "$(git -C "${pkgname}" rev-parse --short HEAD)"
+}
+
+package() {
+ echo >&2 'Packaging the Inkscape extension'
+ install -D -m 644 -t "${pkgdir}/usr/share/inkscape/extensions" \
+ "${srcdir}/${pkgname}/openClosedPath"{.inx,.py}
+
+ echo >&2 'Packaging README.md'
+ install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ "${srcdir}/${pkgname}/README.md"
+}