summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2020-11-25 17:24:28 +1100
committerRhinoceros2020-11-25 17:24:28 +1100
commit1d2315fd5e99b644281d8af5daa62b469da3c405 (patch)
treed643166826ac8ed3012bf3b84df6e856ba7792a9
parentf99a440d33ceb94df4860d6cd5c73dddc43a1676 (diff)
downloadaur-1d2315fd5e99b644281d8af5daa62b469da3c405.tar.gz
Update to r41.f0b15c8-1
* Remove empty conflicts that prevented build * Make pkgdesc actually describe what it does * Fix url * Fix licence and actually install it * Minor style fixes, and remove extra characters
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e93136fddbbd..300c0720daa3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
-# Generated by mksrcinfo v8
-# Mon Jan 16 16:19:07 UTC 2017
pkgbase = inkslides-git
- pkgdesc = Forked and improved version of inkscapeslide-git
- pkgver = r35.fe6cb77
+ pkgdesc = Generate a PDF presentation out of an inkscape SVG document
+ pkgver = r41.f0b15c8
pkgrel = 1
- url = https://github.com/janoliver/inkslides.git
+ url = https://github.com/janoliver/inkslides
arch = i686
arch = x86_64
- license = mit
+ license = MIT
makedepends = git
depends = python
depends = inkscape
diff --git a/PKGBUILD b/PKGBUILD
index adb8d0824530..3c67a44bbfef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
-# Maintainer: Jan Oliver Oelerich <janoliver@oelerich.org>
+# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Jan Oliver Oelerich <janoliver@oelerich.org>
pkgname=inkslides-git
-pkgdesc="Forked and improved version of inkscapeslide-git"
-pkgver=r35.fe6cb77
+pkgdesc='Generate a PDF presentation out of an inkscape SVG document'
+pkgver=r41.f0b15c8
pkgrel=1
arch=('i686' 'x86_64')
-license=('mit')
+license=('MIT')
depends=('python' 'inkscape' 'python-lxml')
makedepends=('git')
-conflicts=('')
-url="https://github.com/janoliver/inkslides.git"
+url='https://github.com/janoliver/inkslides'
source=('git+https://github.com/janoliver/inkslides.git')
_gitname="inkslides"
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$_gitname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- :
-}
-
package() {
- cd "$srcdir/$_gitname"
+ cd "$_gitname"
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
-}
+
+ install -D -m644 MIT-LICENSE "$pkgdir/usr/share/licenses/$pkgname/MIT-LICENSE"
+}