summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpandada82023-02-03 16:50:20 +0800
committerpandada82023-02-03 16:50:20 +0800
commit5a8c1dbbdc8dd09a7e8fb56bb40924ee8fc62c4f (patch)
tree9f83625ef442b91b7e938ee0630a8d8169de1bf2
downloadaur-5a8c1dbbdc8dd09a7e8fb56bb40924ee8fc62c4f.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfc7bb86b814
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = inotify-info-git
+ pkgdesc = Linux inotify info reporting app
+ pkgver = r26.5710dd1
+ pkgrel = 1
+ url = https://github.com/mikesart/inotify-info
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ source = git+https://github.com/mikesart/inotify-info.git
+ md5sums = SKIP
+
+pkgname = inotify-info-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..873863e3e8ee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+inotify-info/
+*.pkg.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..049b780432ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Pandada8 < pandada8@gmail.com >
+
+
+pkgname=inotify-info-git
+_repo_name=inotify-info
+pkgver=r26.5710dd1
+pkgrel=1
+pkgdesc='Linux inotify info reporting app'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url='https://github.com/mikesart/inotify-info'
+license=('MIT')
+source=("git+${url}.git")
+md5sums=(SKIP)
+
+build() {
+ cd ${srcdir}/$_repo_name
+ make
+}
+
+pkgver() {
+ cd ${srcdir}/$_repo_name
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/$_repo_name
+ install _release/inotify-info -Dm755 ${pkgdir}/usr/bin/inotify-info
+}
+