summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Barnes2019-10-30 10:41:36 +1100
committerJake Barnes2019-10-30 10:41:36 +1100
commitcc8122e1aade2d62ee1c9c475fc00b06d3c13fd1 (patch)
treeff786d518bb7d6f1bd21061282660cae85a4d32f
downloadaur-cc8122e1aade2d62ee1c9c475fc00b06d3c13fd1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
-rw-r--r--input-redirection-client-qt.desktop5
4 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e6dde1b38ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = input-redirection-client-qt
+ pkgdesc = Input redirection client for the 3DS using QtGamepad
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://github.com/TuxSH/InputRedirectionClient-Qt
+ arch = x86_64
+ license = MIT
+ depends = qt5-base
+ depends = qt5-gamepad
+ source = https://github.com/TuxSH/InputRedirectionClient-Qt/archive/v2.1.tar.gz
+ source = input-redirection-client-qt.desktop
+ md5sums = 180ab0c1663222fae3770dd2f4654ac1
+ md5sums = a2ca494c5c1b38ac77ee9f44d586c89a
+
+pkgname = input-redirection-client-qt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8306d3997b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.gz
+/*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b120e945a9c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jake Barnes <me@jakebarn.es>
+pkgname=input-redirection-client-qt
+pkgver=2.1
+pkgrel=1
+pkgdesc="Input redirection client for the 3DS using QtGamepad"
+arch=('x86_64')
+url="https://github.com/TuxSH/InputRedirectionClient-Qt"
+license=('MIT')
+depends=('qt5-base' 'qt5-gamepad')
+source=("https://github.com/TuxSH/InputRedirectionClient-Qt/archive/v$pkgver.tar.gz"
+ "input-redirection-client-qt.desktop")
+md5sums=('180ab0c1663222fae3770dd2f4654ac1'
+ 'a2ca494c5c1b38ac77ee9f44d586c89a')
+
+build() {
+ cd "$srcdir/InputRedirectionClient-Qt-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ install -Dm 755 "$srcdir/InputRedirectionClient-Qt-$pkgver/InputRedirectionClient-Qt" "$pkgdir/usr/bin/input-redirection-client-qt"
+ install -Dm 644 "$srcdir/input-redirection-client-qt.desktop" "$pkgdir/usr/share/applications/input-redirection-client-qt.desktop"
+}
diff --git a/input-redirection-client-qt.desktop b/input-redirection-client-qt.desktop
new file mode 100644
index 000000000000..48ada5ee169a
--- /dev/null
+++ b/input-redirection-client-qt.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=InputRedirectionClient-Qt
+Comment=Input redirection client for the 3DS using QtGamepad
+Exec=input-redirection-client-qt
+Type=Application