summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Barnes2019-10-29 23:52:30 +1100
committerJake Barnes2019-10-30 00:01:52 +1100
commit7eb9d6ca9e84f3912765884cfb26625e73da7baa (patch)
treedeb290d6b3e3207ad7b32d716d611deb72381842
downloadaur-7eb9d6ca9e84f3912765884cfb26625e73da7baa.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--input-redirection-client-qt.desktop5
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83c1839a1a22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = input-redirection-client-qt-git
+ pkgdesc = Input redirection client for the 3DS using QtGamepad
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://github.com/TuxSH/InputRedirectionClient-Qt
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-gamepad
+ source = git://github.com/TuxSH/InputRedirectionClient-Qt
+ source = input-redirection-client-qt.desktop
+ md5sums = SKIP
+ md5sums = a2ca494c5c1b38ac77ee9f44d586c89a
+
+pkgname = input-redirection-client-qt-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6968ad6dce64
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.xz
+InputRedirectionClient-Qt/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e52ea4b63964
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jake Barnes <me@jakebarn.es>
+pkgname=input-redirection-client-qt-git
+pkgver=2.1
+pkgrel=1
+pkgdesc="Input redirection client for the 3DS using QtGamepad"
+arch=('x86_64')
+url="https://github.com/TuxSH/InputRedirectionClient-Qt"
+license=('MIT')
+makedepends=('git')
+depends=('qt5-base' 'qt5-gamepad')
+source=("git://github.com/TuxSH/InputRedirectionClient-Qt"
+ "input-redirection-client-qt.desktop")
+md5sums=('SKIP'
+ 'a2ca494c5c1b38ac77ee9f44d586c89a')
+
+pkgver() {
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+}
+
+build() {
+ cd "$srcdir/InputRedirectionClient-Qt"
+ qmake
+ make
+}
+
+package() {
+ install -Dm 755 "$srcdir/InputRedirectionClient-Qt/InputRedirectionClient-Qt" "$pkgdir/usr/bin/input-redirection-client-qt"
+ install -Dm 644 input-redirection-client-qt.desktop "$pkgdir/usr/share/applications/input-redirection-client-qt.desktop"
+}
diff --git a/input-redirection-client-qt.desktop b/input-redirection-client-qt.desktop
new file mode 100644
index 000000000000..48ada5ee169a
--- /dev/null
+++ b/input-redirection-client-qt.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=InputRedirectionClient-Qt
+Comment=Input redirection client for the 3DS using QtGamepad
+Exec=input-redirection-client-qt
+Type=Application