summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArch Nous2019-06-23 22:29:05 +0300
committerArch Nous2019-06-23 22:29:05 +0300
commit378d29253d141360c70468e6257f3ffca5a78ca1 (patch)
tree71158e6298f4569d40aae296a6541594c8e912e5
downloadaur-378d29253d141360c70468e6257f3ffca5a78ca1.tar.gz
v1.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--README20
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5603305c44c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Jun 23 19:28:45 UTC 2019
+pkgbase = input-veikk-config
+ pkgdesc = Configuration utility for input-veikk-dkms: orientation, screen mapping and pressure mapping
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/jlam55555/veikk-s640-driver
+ arch = any
+ license = GPL
+ depends = input-veikk-dkms
+ source = README
+ source = input-veikk-config.sh::https://raw.githubusercontent.com/jlam55555/veikk-s640-driver/master/config.sh
+ sha1sums = 8432d8a7314bc42269e976bdf5a7c75606fd4677
+ sha1sums = 58ef918424a29f4f2bc2a81b069bff07d3d921b1
+
+pkgname = input-veikk-config
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1550b0fffe7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: nous(at)artixlinux.org
+
+pkgname=input-veikk-config
+pkgver=1.1
+pkgrel=1
+pkgdesc="Configuration utility for input-veikk-dkms: orientation, screen mapping and pressure mapping"
+arch=('any')
+url="https://github.com/jlam55555/veikk-s640-driver"
+license=('GPL')
+depends=('input-veikk-dkms')
+source=('README'
+ 'input-veikk-config.sh::https://raw.githubusercontent.com/jlam55555/veikk-s640-driver/master/config.sh')
+sha1sums=('8432d8a7314bc42269e976bdf5a7c75606fd4677'
+ '58ef918424a29f4f2bc2a81b069bff07d3d921b1')
+
+package() {
+ cd "${srcdir}"
+ sed -ri "/^PARM_DIR/ a \\\ncat /usr/share/doc/input-veikk/README" ${pkgname}.sh
+ install -D -m755 -t "${pkgdir}/usr/bin/" "${srcdir}/${pkgname}.sh"
+ install -D -m755 -t "${pkgdir}/usr/share/doc/input-veikk/" "${srcdir}/README"
+}
diff --git a/README b/README
new file mode 100644
index 000000000000..2d20eaee16c5
--- /dev/null
+++ b/README
@@ -0,0 +1,20 @@
+
+Configuration options:
+
+ Orientation:
+ 0: no rotation (default)
+ 1: rotate right 90 deg
+ 2: rotate 180 deg (left-handed mode)
+ 3: rotate left 90 deg
+ Screen mapping (all values in integers percents, e.g., 45):
+ Left: left boundary (default: 0)
+ Top: top boundary (default: 0)
+ Right: right boundary (default: 100)
+ Bottom: bottom boundary (default: 100)
+ Pressure mapping:
+ 0: linear mapping (p_out = p_raw) (default)
+ 1: constant function, half pressure (p_out = p_max / 2)
+ 2: power function, n=1/2 (p_out = sqrt(p_raw))
+ 3: power function, n=2 (p_out = p_raw^2)
+ 4: linear mapping, reduced input pressure (p_out = min(4/3 * p_raw, p_max))
+