summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2020-10-11 02:36:19 +0700
committerAchmad Fathoni2020-10-11 02:36:19 +0700
commit6edcfbeea2893aff819005eb60d571cc48fef9ca (patch)
treea1b3a41cc9d6ad0416ba639d381360e361089d8f
parent378d29253d141360c70468e6257f3ffca5a78ca1 (diff)
downloadaur-6edcfbeea2893aff819005eb60d571cc48fef9ca.tar.gz
v2.0-1
-rw-r--r--PKGBUILD38
-rw-r--r--fix.patch13
2 files changed, 38 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1550b0fffe7..11e81802d6b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
-# Maintainer: nous(at)artixlinux.org
+# Maintainer: fathoni.id(at)gmail.com
+# Contributor: nous(at)artixlinux.org
pkgname=input-veikk-config
-pkgver=1.1
+_pkgname=veikk-linux-driver-gui
+pkgver=2.0
pkgrel=1
-pkgdesc="Configuration utility for input-veikk-dkms: orientation, screen mapping and pressure mapping"
+pkgdesc="A graphical configuration tool to easily customize the module parameters for the input-veikk-dkms"
arch=('any')
-url="https://github.com/jlam55555/veikk-s640-driver"
+url="https://github.com/jlam55555/${_pkgname}"
license=('GPL')
depends=('input-veikk-dkms')
-source=('README'
- 'input-veikk-config.sh::https://raw.githubusercontent.com/jlam55555/veikk-s640-driver/master/config.sh')
-sha1sums=('8432d8a7314bc42269e976bdf5a7c75606fd4677'
- '58ef918424a29f4f2bc2a81b069bff07d3d921b1')
+makedepends=('cmake' 'qt5-tools')
+source=("https://codeload.github.com/jlam55555/${_pkgname}/tar.gz/v${pkgver}" 'fix.patch')
+sha1sums=('09e72cfc11d62f54fab398931060fb7d5bd7258b'
+ '8784d971e57f2d1b3290fb42752b2178a15ba61f')
+
+prepare(){
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ patch --strip=1 --input="${srcdir}/fix.patch"
+}
+
+build(){
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ mkdir -p build && cd build
+ qmake ..
+ make
+}
package() {
- cd "${srcdir}"
- sed -ri "/^PARM_DIR/ a \\\ncat /usr/share/doc/input-veikk/README" ${pkgname}.sh
- install -D -m755 -t "${pkgdir}/usr/bin/" "${srcdir}/${pkgname}.sh"
- install -D -m755 -t "${pkgdir}/usr/share/doc/input-veikk/" "${srcdir}/README"
-}
+ make -C ${srcdir}/${_pkgname}-${pkgver}/build INSTALL_ROOT="$pkgdir" install
+}
+
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..618ddb7e169b
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,13 @@
+diff --git a/veikk-linux-driver-gui.pro b/veikk-linux-driver-gui.pro
+index f1e6559..fc895ee 100644
+--- a/veikk-linux-driver-gui.pro
++++ b/veikk-linux-driver-gui.pro
+@@ -34,6 +34,5 @@ FORMS += \
+ main.ui
+
+ # Default rules for deployment.
+-qnx: target.path = /tmp/$${TARGET}/bin
+-else: unix:!android: target.path = /opt/$${TARGET}/bin
+-!isEmpty(target.path): INSTALLS += target
++target.path = /usr/bin
++INSTALLS += target