summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiuseppe Sellaroli2017-02-07 13:18:01 -0500
committerGiuseppe Sellaroli2017-02-07 13:18:01 -0500
commit5140ecf01165162824fdac99aada11e39102dc99 (patch)
tree1f6670719357861b1b6797448d3f345227e6214c
parentbf3407b7076cc0663bd536e01ed18a0c46e3def2 (diff)
downloadaur-5140ecf01165162824fdac99aada11e39102dc99.tar.gz
implemented move of the built module from a kernel-specific folder to
the root /src folder, to avoid possible problems with lts or custom kernels
-rw-r--r--PKGBUILD12
-rw-r--r--dkms.conf4
-rwxr-xr-xmove-modules9
3 files changed, 18 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31214f45396b..3a3669cb9bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=input-wacom-dkms
_pkgname=input-wacom
pkgver=0.33.0
-pkgrel=3
+pkgrel=4
pkgdesc="Latest Kernel modules form Wacom tablets (DKMS). Useful if your wacom tablet is not supported upstream yet."
arch=('i686' 'x86_64')
url="http://linuxwacom.sourceforge.net/wiki/index.php/Input-wacom"
@@ -12,17 +12,20 @@ optdepends=('xf86-input-wacom: for actually using a Wacom tablet')
install=$pkgname.install
source=("http://downloads.sourceforge.net/project/linuxwacom/xf86-input-wacom/input-wacom/$_pkgname-$pkgver.tar.bz2"
"dkms.conf"
- "blacklist-input-wacom-dkms.conf")
+ "blacklist-input-wacom-dkms.conf"
+ "move-modules")
noextract=()
md5sums=('a21ee9b048569ad78c41c1480097da10'
- 'cb4e089c7e175211b5ae4c2bab93f6e4'
- 'da99119208e69b9a611b1809e1f241f8')
+ '3c3ebe8e6affc14b266f67f8a71833b6'
+ 'da99119208e69b9a611b1809e1f241f8'
+ '8a851dede08da29c2810fb58e8b69910')
package() {
installdir="$pkgdir/usr/src/$_pkgname-$pkgver"
install -dm755 "$installdir"
install -m644 "$srcdir/dkms.conf" "$installdir"
+ install -m644 "$srcdir/move-modules" "$installdir"
install -dm755 "$pkgdir/etc/modprobe.d"
install -m644 "$srcdir/blacklist-input-wacom-dkms.conf" "$pkgdir/etc/modprobe.d"
@@ -39,4 +42,5 @@ package() {
install -m644 "${srcdir}/${_pkgname}-${pkgver}/$f" "$installdir/$f"
done
chmod +x "$installdir/configure"
+ chmod +x "$installdir/move-modules"
}
diff --git a/dkms.conf b/dkms.conf
index 3064bfa972e5..d840b527622a 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,12 +1,10 @@
PACKAGE_NAME="input-wacom"
PACKAGE_VERSION="0.33.0"
-MAKE[0]="./configure && make"
+MAKE[0]="./configure && make && ./move-modules"
BUILT_MODULE_NAME[0]="wacom"
DEST_MODULE_NAME[0]="wacom_dkms"
BUILT_MODULE_NAME[1]="wacom_w8001"
DEST_MODULE_NAME[1]="wacom_w8001_dkms"
-BUILT_MODULE_LOCATION[0]="4.5/"
-BUILT_MODULE_LOCATION[1]="4.5/"
DEST_MODULE_LOCATION[0]="/kernel/drivers/input/tablet"
DEST_MODULE_LOCATION[1]="/kernel/drivers/input/touchscreen"
AUTOINSTALL="yes"
diff --git a/move-modules b/move-modules
new file mode 100755
index 000000000000..27f08626d26f
--- /dev/null
+++ b/move-modules
@@ -0,0 +1,9 @@
+#! /bin/sh
+# Move the compiled kernel modules wacom.ko and wacom_w8001.ko from the kernel specific folder (e.g., 3.17, 4.5) to the root folder.
+
+for f in `find -name "wacom.ko" -o -name "wacom_w8001.ko" -type f`
+do
+ mv $f .
+done
+
+