summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCelti Burroughs2020-11-08 23:10:14 -0700
committerCelti Burroughs2020-11-08 23:10:14 -0700
commit0e7ea89a6cf58432794d4237b8a64789e000dfb8 (patch)
treee915b7bc25bc08785c833510a985662c5b69cc9b
downloadaur-0e7ea89a6cf58432794d4237b8a64789e000dfb8.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06084a26f8fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = inputplug
+ pkgdesc = Xinput hotplug event daemon
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/andrewshadura/inputplug
+ arch = x86_64
+ license = MIT
+ makedepends = libxi
+ makedepends = libxfixes
+ depends = libxcb
+ source = inputplug-0.3.tar.gz::https://github.com/andrewshadura/inputplug/archive/0.3.tar.gz
+ sha256sums = acac8e3972f3f10f9b6791321d2441e6b54d93d97c2de81e13eb14734a635ef7
+
+pkgname = inputplug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d534357763fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Celti Burroughs <celti@celti.name>
+pkgname=inputplug
+pkgver=0.3
+pkgrel=1
+pkgdesc="Xinput hotplug event daemon"
+arch=('x86_64')
+url="https://github.com/andrewshadura/inputplug"
+license=('MIT')
+depends=('libxcb')
+makedepends=('libxi' 'libxfixes')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/andrewshadura/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('acac8e3972f3f10f9b6791321d2441e6b54d93d97c2de81e13eb14734a635ef7')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i 's/CFLAGS =/CFLAGS +=/' GNUmakefile
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make -f GNUmakefile
+ gzip inputplug.1
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 inputplug.1.gz "$pkgdir/usr/share/man/man1/inputplug.1.gz"
+ install -Dm755 inputplug "$pkgdir/usr/bin/inputplug"
+}