summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Peter2021-07-05 17:47:40 +0200
committerDavid Peter2021-07-05 17:47:40 +0200
commitf73bb43e0a12e1a0e6ec62a151e7b99cab6b3fff (patch)
tree3ddb7ffc1dc7a79953b8f86cfbf7af3cf20d73c8
parent6b7074fb49d0b8a2debdfa325cab28ea46d4b1f4 (diff)
downloadaur-f73bb43e0a12e1a0e6ec62a151e7b99cab6b3fff.tar.gz
Fix problem with 'npm install' on newer npm versions
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5d9337d4f81..3ea4ef5ea0e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _npmname=insect
_npmver=5.6.0
pkgname=insect
pkgver=5.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="High precision scientific calculator with support for physical units"
arch=(any)
url="https://github.com/sharkdp/insect"
@@ -20,11 +20,13 @@ package() {
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
- npm install -g --user root --prefix "$pkgdir/usr" "$srcdir"/$_npmname-$_npmver.tgz
+ npm install -g --prefix "$pkgdir/usr" "$srcdir"/$_npmname-$_npmver.tgz
# see https://wiki.archlinux.org/index.php/Node.js_package_guidelines
find "${pkgdir}"/usr -type d -exec chmod 755 {} +
find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+
+ chown -R root:root "${pkgdir}"
}
# vim:set ts=2 sw=2 et: