diff options
author | géballin | 2023-05-06 23:35:58 +0200 |
---|---|---|
committer | géballin | 2023-05-06 23:35:58 +0200 |
commit | 301e3c512c627641ee0517fce95b1e98d2cfb1f2 (patch) | |
tree | dfdf3878a37d2342eeb9c886a18edd5fd0cffbff | |
parent | 4ca64f7ec169d81e18a67bbd74992e3b18e8b153 (diff) | |
download | aur-301e3c512c627641ee0517fce95b1e98d2cfb1f2.tar.gz |
Thanks to dreieck, improve the build process.
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 29 |
2 files changed, 25 insertions, 8 deletions
@@ -1,6 +1,6 @@ pkgbase = insight-git pkgdesc = Insight is a graphical user interface to GDB, the GNU Debugger written in Tcl/Tk. - pkgver = bundled.tcl.r467.g3be6b22 + pkgver = 14.0.50.20230506_git.r646.f988690 pkgrel = 1 url = https://sourceware.org/git/?p=insight.git arch = x86_64 @@ -13,6 +13,8 @@ pkgbase = insight-git depends = tk-itk depends = tcl-combobox depends = iwidgets + provides = insight + conflicts = insight options = !buildflags source = git+https://sourceware.org/git/insight.git source = build.sh @@ -1,6 +1,6 @@ # Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr> pkgname=insight-git -pkgver=bundled.tcl.r467.g3be6b22 +pkgver=14.0.50.20230506_git.r646.f988690 pkgrel=1 pkgdesc="Insight is a graphical user interface to GDB, the GNU Debugger written in Tcl/Tk." url="https://sourceware.org/git/?p=insight.git" @@ -9,7 +9,8 @@ license=('GPL3') depends=('tcl' 'tk' 'gdb' 'tk-itk' 'tcl-combobox' 'iwidgets') optdepends=() makedepends=(git) -conflicts=() +provides=("insight") +conflicts=('insight') replaces=() backup=() options=('!buildflags') @@ -30,11 +31,21 @@ md5sums=('SKIP' pkgver() { cd insight - git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' + + _ver="$(sed -E -e "s|DATE|$(git log -1 --date=format:'%Y%m%d' --format='%ad')|" binutils-gdb/gdb/version.in | tr '-' '_')" + _rev="$(git rev-list --count HEAD)" + _hash="$(git rev-parse --short HEAD)" + + if [ -z "${_ver}" ]; then + error "Could not determine version." + return 1 + else + printf '%s' "${_ver}.r${_rev}.${_hash}" + fi } prepare() { - git -C insight submodule update --init --recursive + git -C insight submodule update --init --recursive --progress } build() { @@ -52,12 +63,16 @@ build() { package() { cd insight make DESTDIR="${pkgdir}" install-host-nogcc + + ## Clean up files we do not want (already installed by gdb package) cd ${pkgdir}/usr - rm bin/g* - rm -rf include + rm etc/gprofng.rc rm -rf lib - rm lib64/lib* + rm lib64/lib* mv lib64 lib + rm bin/g* + rm -rf include + rm -rf lib/gprofng rm -rf share/info rm -rf share/locale rm -rf share/man |