summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2021-11-12 13:24:26 +0100
committergéballin2021-11-12 13:24:26 +0100
commit4ca64f7ec169d81e18a67bbd74992e3b18e8b153 (patch)
treecf1246f1eb388c52ce6bf0c7738c1641db7c564a
parentc9981af5c9f6a3cc5569a1919158cc6eb7d9d825 (diff)
downloadaur-4ca64f7ec169d81e18a67bbd74992e3b18e8b153.tar.gz
Correcting license GPL3 name.
Add git as makedepends. Add the pkgver function.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53f09dcdd090..504d3e917802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = insight-git
pkgdesc = Insight is a graphical user interface to GDB, the GNU Debugger written in Tcl/Tk.
- pkgver = 1
- pkgrel = 2
+ pkgver = bundled.tcl.r467.g3be6b22
+ pkgrel = 1
url = https://sourceware.org/git/?p=insight.git
arch = x86_64
arch = i686
- license = GPLv3
- makedepends = gcc
- makedepends = make
+ license = GPL3
+ makedepends = git
depends = tcl
depends = tk
depends = gdb
diff --git a/PKGBUILD b/PKGBUILD
index 62c6d3153182..f7c4f9262d3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
pkgname=insight-git
-pkgver=1
-pkgrel=2
+pkgver=bundled.tcl.r467.g3be6b22
+pkgrel=1
pkgdesc="Insight is a graphical user interface to GDB, the GNU Debugger written in Tcl/Tk."
url="https://sourceware.org/git/?p=insight.git"
arch=('x86_64' 'i686')
-license=('GPLv3')
+license=('GPL3')
depends=('tcl' 'tk' 'gdb' 'tk-itk' 'tcl-combobox' 'iwidgets')
optdepends=()
-makedepends=(gcc make)
+makedepends=(git)
conflicts=()
replaces=()
backup=()
@@ -28,6 +28,11 @@ md5sums=('SKIP'
'a657612d67bc37b53b874b07aaf68873'
'3f329bccc0724dd689143c45c583f876')
+pkgver() {
+ cd insight
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
git -C insight submodule update --init --recursive
}