summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2021-11-07 21:51:21 +0100
committergéballin2021-11-07 21:51:21 +0100
commit883771aef81406cbc54eae6c328039a29bcb51ef (patch)
tree7292fdebc30681e7da302c38b7d62ed477667d18
downloadaur-883771aef81406cbc54eae6c328039a29bcb51ef.tar.gz
I finaly did it, insight for archlinux ready to use.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD59
-rw-r--r--binutils-gdb_config_override.m4.patch11
-rw-r--r--build.sh17
-rw-r--r--configure.ac.patch14
-rw-r--r--gdb_acinclude.m4.patch13
-rw-r--r--libgui_acinclude.m4.patch14
7 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c45e0272c9c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = insight-git
+ pkgdesc = Insight is a graphical user interface to GDB, the GNU Debugger written in Tcl/Tk.
+ pkgver = 1
+ pkgrel = 1
+ url = https://sourceware.org/git/?p=insight.git
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ makedepends = gcc
+ makedepends = make
+ depends = tcl
+ depends = tk
+ depends = gdb
+ depends = itk
+ depends = tcl-combobox
+ depends = iwidgets
+ options = !buildflags
+ source = git+https://sourceware.org/git/insight.git
+ source = build.sh
+ source = gdb_acinclude.m4.patch
+ source = libgui_acinclude.m4.patch
+ source = configure.ac.patch
+ source = binutils-gdb_config_override.m4.patch
+ md5sums = SKIP
+ md5sums = 4817d3935ad0815c3a76cbbc11cd0b1c
+ md5sums = a4a50d98e6cfdc38bc8187b34ce451fa
+ md5sums = 67588c209da7505a07c44532f6e973ae
+ md5sums = a657612d67bc37b53b874b07aaf68873
+ md5sums = 3f329bccc0724dd689143c45c583f876
+
+pkgname = insight-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05d7c7fa12b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=insight-git
+pkgver=1
+pkgrel=1
+pkgdesc="Insight is a graphical user interface to GDB, the GNU Debugger written in Tcl/Tk."
+url="https://sourceware.org/git/?p=insight.git"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=('tcl' 'tk' 'gdb' 'itk' 'tcl-combobox' 'iwidgets')
+optdepends=()
+makedepends=(gcc make)
+conflicts=()
+replaces=()
+backup=()
+options=('!buildflags')
+install=
+source=(git+https://sourceware.org/git/insight.git
+ build.sh
+ gdb_acinclude.m4.patch
+ libgui_acinclude.m4.patch
+ configure.ac.patch
+ binutils-gdb_config_override.m4.patch)
+
+md5sums=('SKIP'
+ '4817d3935ad0815c3a76cbbc11cd0b1c'
+ 'a4a50d98e6cfdc38bc8187b34ce451fa'
+ '67588c209da7505a07c44532f6e973ae'
+ 'a657612d67bc37b53b874b07aaf68873'
+ '3f329bccc0724dd689143c45c583f876')
+
+prepare() {
+ git -C insight submodule update --init --recursive
+}
+
+build() {
+ cd insight
+ patch -u libgui/acinclude.m4 -i ../libgui_acinclude.m4.patch
+ patch -u binutils-gdb/gdb/acinclude.m4 -i ../gdb_acinclude.m4.patch
+ patch -u binutils-gdb/config/override.m4 -i ../binutils-gdb_config_override.m4.patch
+ patch -u configure.ac -i ../configure.ac.patch
+ aclocal
+ autoconf
+ sh ../build.sh
+ make
+ }
+
+package() {
+ cd insight
+ make DESTDIR="${pkgdir}" install-host-nogcc
+ cd ${pkgdir}/usr
+ rm bin/g*
+ rm -rf include
+ rm -rf lib
+ rm lib64/lib*
+ mv lib64 lib
+ rm -rf share/info
+ rm -rf share/locale
+ rm -rf share/man
+ }
diff --git a/binutils-gdb_config_override.m4.patch b/binutils-gdb_config_override.m4.patch
new file mode 100644
index 000000000000..378995219332
--- /dev/null
+++ b/binutils-gdb_config_override.m4.patch
@@ -0,0 +1,11 @@
+--- ./insight/binutils-gdb/config/override.m4.a 2021-10-31 19:59:43.643542843 +0100
++++ ./insight/binutils-gdb/config/override.m4.b 2021-10-31 16:15:57.227235135 +0100
+@@ -44,7 +44,7 @@
+ [m4_fatal([Please use exactly Autoconf ]_GCC_AUTOCONF_VERSION[ instead of ]m4_defn([m4_PACKAGE_VERSION])[.])])
+ ])
+ m4_define([AC_INIT], m4_defn([AC_INIT])[
+-_GCC_AUTOCONF_VERSION_CHECK
++dnl _GCC_AUTOCONF_VERSION_CHECK
+ ])
+
+
diff --git a/build.sh b/build.sh
new file mode 100644
index 000000000000..12d7a9ffb2cb
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,17 @@
+./configure --prefix=/usr \
+--libdir=/usr/lib64 \
+--disable-binutils \
+--disable-elfcpp \
+--disable-gas \
+--disable-gold \
+--disable-gprof \
+--disable-ld \
+--disable-rpath \
+--disable-zlib \
+--enable-sim \
+--with-gdb-datadir=/usr/share/insight \
+--with-jit-reader-dir=/usr/lib64/insight \
+--with-separate-debug-dir='/usr/lib/debug' \
+--with-expat \
+--with-python \
+--without-libunwind
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..bdf5a946b140
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,14 @@
+--- ../configure.ac 2020-03-31 21:04:23.921049403 +0200
++++ ./configure.ac 2020-04-08 16:42:00.463683714 +0200
+@@ -60,9 +60,9 @@
+ else mkdir bundle
+ fi
+
+-dnl Was "cp -a -T binutils-gdb bundle", but the following tar-based tree copy
++dnl Was "cp -a -T binut;5Dils-gdb bundle", but the following tar-based tree copy
+ dnl is much faster on MinGW.
+-(cd binutils-gdb; tar cf - *) | (cd bundle; tar xpf - --same-owner)
++cp -a -T binutils-gdb bundle
+
+ cp -a gdbtk bundle/gdb/
+ cp -a testsuite bundle/gdb/
diff --git a/gdb_acinclude.m4.patch b/gdb_acinclude.m4.patch
new file mode 100644
index 000000000000..cbd9a9a4a867
--- /dev/null
+++ b/gdb_acinclude.m4.patch
@@ -0,0 +1,13 @@
+diff --git a/gdb/acinclude.m4 b/gdb/acinclude.m4
+index 11cc0bc241..ad150bac3c 100644
+--- a/binutils-gdb/gdb/acinclude.m4
++++ b/binutils-gdb/gdb/acinclude.m4
+@@ -258,7 +258,7 @@ dnl Note: you must use first use SC_LOAD_TCLCONFIG!
+ AC_DEFUN([CY_AC_TCL_PRIVATE_HEADERS], [
+ AC_MSG_CHECKING([for Tcl private headers])
+ private_dir=""
+- dir=`echo ${TCL_INCLUDE_SPEC}/tcl-private/generic | sed -e s/-I//`
++ dir=`echo ${TCL_INCLUDE_SPEC} | sed -e s/-I//`
+ if test -f ${dir}/tclInt.h ; then
+ private_dir=${dir}
+ fi
diff --git a/libgui_acinclude.m4.patch b/libgui_acinclude.m4.patch
new file mode 100644
index 000000000000..6f0ac11e88be
--- /dev/null
+++ b/libgui_acinclude.m4.patch
@@ -0,0 +1,14 @@
+diff --git a/libgui/acinclude.m4 b/libgui/acinclude.m4
+index 1b5a83b..082a49c 100644
+--- a/libgui/acinclude.m4
++++ b/libgui/acinclude.m4
+@@ -8,8 +8,7 @@ dnl Note: you must use first use SC_LOAD_TCLCONFIG!
+ AC_DEFUN([CY_AC_TCL_PRIVATE_HEADERS], [
+ AC_MSG_CHECKING([for Tcl private headers])
+ private_dir=""
+- for dir in "${TCL_INCLUDE_SPEC}/tcl-private" "${TCL_SRC_DIR}"; do
+- dir=`echo "${dir}/generic" | sed -e s/-I//`
++ for dir in "${TCL_INCLUDE_SPEC}" "${TCL_SRC_DIR}"; do
+ if test -f "${dir}/tclInt.h"; then
+ private_dir="${dir}"
+ break