summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteelstrings2017-08-21 19:22:43 +0200
committersteelstrings2017-08-21 19:22:43 +0200
commitea49e5038d5859df3922f6c3c42388894e38977d (patch)
tree68e28d8647cc76ee4ebd64db51b5027b31c69b8a
downloadaur-ea49e5038d5859df3922f6c3c42388894e38977d.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c00559a2830
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = insignia-icon-theme-git
+ pkgdesc = Insignia Icon Theme by Francisco Villarroel
+ pkgver = 68.2a1ef79
+ pkgrel = 1
+ url = https://github.com/fsvh/insignia
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-update-icon-cache
+ provides = insignia-icon-theme-git
+ conflicts = insignia-icon-theme-git
+ source = git+https://github.com/fsvh/insignia.git
+ sha256sums = SKIP
+
+pkgname = insignia-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d62890b70d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: steelstrings <steelstrings.of.a{at}gmail{dot}com>
+# based on captiva-icons-git by tydell
+
+pkgname=insignia-icon-theme-git
+_pkgname=insignia
+pkgver=68.2a1ef79
+pkgrel=1
+pkgdesc="Insignia Icon Theme by Francisco Villarroel"
+arch=('any')
+url="https://github.com/fsvh/insignia"
+license=('GPL3')
+depends=('gtk-update-icon-cache')
+makedepends=('git')
+provides=('insignia-icon-theme-git')
+conflicts=('insignia-icon-theme-git')
+source=('git+https://github.com/fsvh/insignia.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+
+ # create theme dirs
+ install -d -m 755 "$pkgdir"/usr/share/icons/Insignia
+
+ # install theme
+ cd $srcdir/$_pkgname/Insignia
+ cp -r . "$pkgdir"/usr/share/icons/Insignia/
+}