summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregory Schier2017-04-05 19:29:27 -0700
committerGregory Schier2017-04-05 19:47:13 -0700
commit2987690887e4c599561c40da4baa4e883d9fe840 (patch)
treee6c9c23c281c93e09de31ec09a7000a10e8011de
parent949f6ea68f640a1c6cc180b6ea96f9208c56d38e (diff)
downloadaur-2987690887e4c599561c40da4baa4e883d9fe840.tar.gz
Fixed libcurl dependency and updated for 5.0.1
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
-rw-r--r--README.md12
-rwxr-xr-xinsomnia.sh3
5 files changed, 52 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d560ae89aa4d..fb112a5ead9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = insomnia
pkgdesc = A simple and beautiful REST API and HTTP client
- pkgver = 5.0.0
+ pkgver = 5.0.1
pkgrel = 1
- url = https://insomnia.rest/
- arch = i686
+ url = http://insomnia.rest/
arch = x86_64
+ depends = libcurl-compat
options = !strip
options = !upx
- source = https://downloads.insomnia.rest/linux/insomnia_5.0.0_amd64.deb
- md5sums = 5d0fd951e027ddd0ba7c401d90fc132e
+ source = https://downloads.insomnia.rest/linux/insomnia_5.0.1_amd64.deb
+ source = insomnia.sh
+ md5sums = 7f44b1f6807e8aabd5d018a2a9eb3ad8
+ md5sums = 7c5c262829ac604b83452874e6631ff8
pkgname = insomnia
diff --git a/.gitignore b/.gitignore
index 7d402c14bc7a..15472c4fcb80 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
src
pkg
-insomnia-*.deb
-insomnia-*-x86_64.pkg.tar*
-.idea \ No newline at end of file
+insomnia*.deb
+insomnia*.pkg.tar*
+.idea
+.DS_Store \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d461617e3e20..6db86dadf650 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,42 @@
# Maintainer: Renaud Littolff <rlittolff@gmail.com>
+# Contributor: Gregory Schier <greg@schier.co>
pkgname=insomnia
-pkgver=5.0.0
+pkgver=5.0.1
pkgrel=1
pkgdesc="A simple and beautiful REST API and HTTP client"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://insomnia.rest/"
options=('!strip' '!upx')
+depends=('libcurl-compat')
-source=("https://downloads.insomnia.rest/linux/insomnia_${pkgver}_amd64.deb")
-md5sums=('5d0fd951e027ddd0ba7c401d90fc132e')
+source=(
+ "https://downloads.insomnia.rest/linux/insomnia_${pkgver}_amd64.deb"
+ "insomnia.sh"
+)
package() {
- cd "${srcdir}"
+ # Define some helpers
+ SCRIPT_PATH=${pkgdir}/opt/Insomnia/start-insomnia.sh
+ # Extract the core package
tar -xf data.tar.xz -C "${pkgdir}"
- install -d "${pkgdir}"/usr/share/applications
- install -d "${pkgdir}"/usr/share/icons
- install -d "${pkgdir}"/opt/Insomnia
-
- chmod -R go-w "${pkgdir}"/usr
+ # Install the necessary parts
+ install -d ${pkgdir}/usr/share/applications
+ install -d ${pkgdir}/usr/share/icons
+ install -d ${pkgdir}/opt/Insomnia
+ # Setup usr folder
+ chmod -R go-w ${pkgdir}/usr
mkdir -p ${pkgdir}/usr/bin
- ln -s /opt/Insomnia/insomnia ${pkgdir}/usr/bin/insomnia
+
+ # Setup the start script and permissions
+ cp ${srcdir}/insomnia.sh ${SCRIPT_PATH}
+ chmod 755 ${SCRIPT_PATH}
+ ln -s ${SCRIPT_PATH} ${pkgdir}/usr/bin/insomnia
}
+
+# Generated by `$ makepkg -g >> PKGBUILD`
+md5sums=('7f44b1f6807e8aabd5d018a2a9eb3ad8'
+ '7c5c262829ac604b83452874e6631ff8')
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5f96ecd2b95a
--- /dev/null
+++ b/README.md
@@ -0,0 +1,12 @@
+# Insomnia AUR Package
+
+```shell
+# Generate md5
+makepkg -g >> PKGBUILD # then delete old ones
+
+# Generate new .SRCINFO
+makepkg --printsrcinfo > .SRCINFO
+
+# Test a build
+makepkg
+``` \ No newline at end of file
diff --git a/insomnia.sh b/insomnia.sh
new file mode 100755
index 000000000000..18fe7a879b3a
--- /dev/null
+++ b/insomnia.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+LD_PRELOAD=/usr/lib/libcurl.so.3 /opt/insomnia/insomnia