summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-27 11:06:10 +1300
committercaltlgin2020-10-27 11:06:10 +1300
commit6bb273e70f2485c9b0b8b252ac6c1c807af166ef (patch)
tree05ea83c565c018b068ba56038aec7c2fff118c2e
parent93bfaafb33c16e6a6fc1b7327b471525601d6f41 (diff)
downloadaur-6bb273e70f2485c9b0b8b252ac6c1c807af166ef.tar.gz
Update to v2020.4.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 529a1531f2e0..81613cc5de1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = insomnia-designer-bin
pkgdesc = Collaborative API Design Tool for designing, testing and managing OpenAPI specifications
- pkgver = 2020.4.1
+ pkgver = 2020.4.2
pkgrel = 1
url = https://insomnia.rest
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = insomnia-designer-bin
depends = xdg-utils
provides = insomnia-designer
conflicts = insomnia-designer
- source = https://github.com/Kong/insomnia/releases/download/designer@2020.4.1/Insomnia.Designer-2020.4.1.deb
- source = Insomnia-Designer-2020.4.1-LICENSE::https://github.com/Kong/insomnia/raw/master/LICENSE
- sha256sums = 07abf18fbe6fa20b9b710dee9f0a770dd4c8920c7af386e1e856193b22cd4a1a
- sha256sums = SKIP
+ source = https://github.com/Kong/insomnia/releases/download/designer@2020.4.2/Insomnia.Designer-2020.4.2.deb
+ source = license-fa85501efdb0aff74d4fcca4207664711486c430::https://github.com/Kong/insomnia/raw/fa85501efdb0aff74d4fcca4207664711486c430/LICENSE
+ sha256sums = 92d672fcdbd53aa7000449e6a8d296d847fb3de543657e82f4145a1906234ea1
+ sha256sums = cc91b5641bbbf592a69ca5f7b45807efba470068e815fc7682a42022bbd3cbb9
pkgname = insomnia-designer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 75fe21b21bf5..9796729fdd48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,11 @@
_pkgname='Insomnia-Designer'
pkgname="${_pkgname,,}-bin"
-pkgver=2020.4.1
+
+pkgver=2020.4.2
pkgrel=1
+_commit_license='fa85501efdb0aff74d4fcca4207664711486c430'
+
pkgdesc='Collaborative API Design Tool for designing, testing and managing OpenAPI specifications'
arch=('x86_64')
url='https://insomnia.rest'
@@ -13,19 +16,18 @@ depends=('libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxslt' 'node
provides=("${_pkgname,,}")
conflicts=("${_pkgname,,}")
source=("${_url_source}/releases/download/designer@${pkgver}/${_pkgname/-/.}-${pkgver}.deb"
- "${_pkgname}-${pkgver}-LICENSE::${_url_source}/raw/master/LICENSE")
-# NB: updpkgsums: LICENSE == SKIP
-sha256sums=('07abf18fbe6fa20b9b710dee9f0a770dd4c8920c7af386e1e856193b22cd4a1a'
- 'SKIP')
+ "license-${_commit_license}::${_url_source}/raw/${_commit_license}/LICENSE")
+sha256sums=('92d672fcdbd53aa7000449e6a8d296d847fb3de543657e82f4145a1906234ea1'
+ 'cc91b5641bbbf592a69ca5f7b45807efba470068e815fc7682a42022bbd3cbb9')
package() {
- tar -xvf data.tar.xz -C "${pkgdir}"
+ tar -xvf 'data.tar.xz' -C "${pkgdir}"
rm -rf "${pkgdir}/usr/share/doc"
- install -d "${pkgdir}/usr/bin"
- ln -sf "/opt/${_pkgname/-/ }/${_pkgname,,}" "${pkgdir}/usr/bin/${_pkgname,,}"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" \
- "${pkgdir}/opt/${_pkgname/-/ }/"{'LICENSE.electron.txt','LICENSES.chromium.html'}
- install -Dm644 "${_pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -dv "${pkgdir}/usr/bin"
+ ln -sfv "/opt/${_pkgname/-/ }/${_pkgname,,}" -t "${pkgdir}/usr/bin"
+ install -Dvm644 "${pkgdir}/opt/${_pkgname/-/ }/"{'LICENSE.electron.txt','LICENSES.chromium.html'} \
+ -t "${pkgdir}/usr/share/licenses/${_pkgname,,}"
+ install -Dvm644 "license-${_commit_license}" "${pkgdir}/usr/share/licenses/${_pkgname,,}/LICENSE"
}
# vim: ts=2 sw=2 et: