summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-05 07:01:38 +1300
committercaltlgin2020-10-05 07:01:38 +1300
commit93bfaafb33c16e6a6fc1b7327b471525601d6f41 (patch)
treeda3e6f3f0746a0b510a9af3c344520935ae54920
downloadaur-93bfaafb33c16e6a6fc1b7327b471525601d6f41.tar.gz
Add to AUR
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..529a1531f2e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = insomnia-designer-bin
+ pkgdesc = Collaborative API Design Tool for designing, testing and managing OpenAPI specifications
+ pkgver = 2020.4.1
+ pkgrel = 1
+ url = https://insomnia.rest
+ arch = x86_64
+ license = MIT
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = libsecret
+ depends = libxss
+ depends = libxslt
+ depends = nodejs
+ depends = nss
+ depends = xdg-utils
+ provides = insomnia-designer
+ conflicts = insomnia-designer
+ source = https://github.com/Kong/insomnia/releases/download/designer@2020.4.1/Insomnia.Designer-2020.4.1.deb
+ source = Insomnia-Designer-2020.4.1-LICENSE::https://github.com/Kong/insomnia/raw/master/LICENSE
+ sha256sums = 07abf18fbe6fa20b9b710dee9f0a770dd4c8920c7af386e1e856193b22cd4a1a
+ sha256sums = SKIP
+
+pkgname = insomnia-designer-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75fe21b21bf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='Insomnia-Designer'
+pkgname="${_pkgname,,}-bin"
+pkgver=2020.4.1
+pkgrel=1
+pkgdesc='Collaborative API Design Tool for designing, testing and managing OpenAPI specifications'
+arch=('x86_64')
+url='https://insomnia.rest'
+_url_source='https://github.com/Kong/insomnia'
+license=('MIT')
+depends=('libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxslt' 'nodejs' 'nss' 'xdg-utils')
+provides=("${_pkgname,,}")
+conflicts=("${_pkgname,,}")
+source=("${_url_source}/releases/download/designer@${pkgver}/${_pkgname/-/.}-${pkgver}.deb"
+ "${_pkgname}-${pkgver}-LICENSE::${_url_source}/raw/master/LICENSE")
+# NB: updpkgsums: LICENSE == SKIP
+sha256sums=('07abf18fbe6fa20b9b710dee9f0a770dd4c8920c7af386e1e856193b22cd4a1a'
+ 'SKIP')
+
+package() {
+ tar -xvf data.tar.xz -C "${pkgdir}"
+ rm -rf "${pkgdir}/usr/share/doc"
+ install -d "${pkgdir}/usr/bin"
+ ln -sf "/opt/${_pkgname/-/ }/${_pkgname,,}" "${pkgdir}/usr/bin/${_pkgname,,}"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" \
+ "${pkgdir}/opt/${_pkgname/-/ }/"{'LICENSE.electron.txt','LICENSES.chromium.html'}
+ install -Dm644 "${_pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: