summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-25 06:44:25 +1300
committercaltlgin2020-11-25 06:44:25 +1300
commit99e107b36245aa6683947ccf345fcd7e2e488f3e (patch)
tree16134145b00675ae5fc5b1e85f0d35b952152d5a
parent6bb273e70f2485c9b0b8b252ac6c1c807af166ef (diff)
downloadaur-99e107b36245aa6683947ccf345fcd7e2e488f3e.tar.gz
Refactor source license download
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD7
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81613cc5de1e..288dbb41ca13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,7 @@ pkgbase = insomnia-designer-bin
provides = insomnia-designer
conflicts = insomnia-designer
source = https://github.com/Kong/insomnia/releases/download/designer@2020.4.2/Insomnia.Designer-2020.4.2.deb
- source = license-fa85501efdb0aff74d4fcca4207664711486c430::https://github.com/Kong/insomnia/raw/fa85501efdb0aff74d4fcca4207664711486c430/LICENSE
+ source = Insomnia-Designer-2020.4.2-license::https://github.com/Kong/insomnia/raw/designer@2020.4.2/LICENSE
sha256sums = 92d672fcdbd53aa7000449e6a8d296d847fb3de543657e82f4145a1906234ea1
sha256sums = cc91b5641bbbf592a69ca5f7b45807efba470068e815fc7682a42022bbd3cbb9
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 9796729fdd48..5d1f0e8de77e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,8 @@
_pkgname='Insomnia-Designer'
pkgname="${_pkgname,,}-bin"
-
pkgver=2020.4.2
pkgrel=1
-_commit_license='fa85501efdb0aff74d4fcca4207664711486c430'
-
pkgdesc='Collaborative API Design Tool for designing, testing and managing OpenAPI specifications'
arch=('x86_64')
url='https://insomnia.rest'
@@ -16,7 +13,7 @@ depends=('libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxslt' 'node
provides=("${_pkgname,,}")
conflicts=("${_pkgname,,}")
source=("${_url_source}/releases/download/designer@${pkgver}/${_pkgname/-/.}-${pkgver}.deb"
- "license-${_commit_license}::${_url_source}/raw/${_commit_license}/LICENSE")
+ "${_pkgname}-${pkgver}-license::${_url_source}/raw/designer@${pkgver}/LICENSE")
sha256sums=('92d672fcdbd53aa7000449e6a8d296d847fb3de543657e82f4145a1906234ea1'
'cc91b5641bbbf592a69ca5f7b45807efba470068e815fc7682a42022bbd3cbb9')
@@ -27,7 +24,7 @@ package() {
ln -sfv "/opt/${_pkgname/-/ }/${_pkgname,,}" -t "${pkgdir}/usr/bin"
install -Dvm644 "${pkgdir}/opt/${_pkgname/-/ }/"{'LICENSE.electron.txt','LICENSES.chromium.html'} \
-t "${pkgdir}/usr/share/licenses/${_pkgname,,}"
- install -Dvm644 "license-${_commit_license}" "${pkgdir}/usr/share/licenses/${_pkgname,,}/LICENSE"
+ install -Dvm644 "${_pkgname}-${pkgver}-license" "${pkgdir}/usr/share/licenses/${_pkgname,,}/LICENSE"
}
# vim: ts=2 sw=2 et: