summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-08 15:42:02 +1300
committercaltlgin2020-10-08 15:42:02 +1300
commit85fc5c0037ba794a4334d2aff3bbfaf67849e8c6 (patch)
treee1dfe052d0f44f4397cd6453a80da0627c7dd78b
downloadaur-85fc5c0037ba794a4334d2aff3bbfaf67849e8c6.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6e008ce1224
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = inspektor
+ pkgdesc = View metadata information on files
+ pkgver = 1.0.32
+ pkgrel = 1
+ url = https://github.com/hezral/inspektor
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = attr
+ depends = gtk3
+ depends = perl-image-exiftool
+ depends = python
+ source = inspektor-1.0.32.tar.gz::https://github.com/hezral/inspektor/archive/1.0.32.tar.gz
+ sha256sums = 41057ef4efb61a24cfb6cf70a2e45381542774635f5080803dba5ba0b5429444
+
+pkgname = inspektor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b5844512fb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='inspektor'
+pkgver=1.0.32
+pkgrel=1
+pkgdesc='View metadata information on files'
+arch=('any')
+url='https://github.com/hezral/inspektor'
+license=('GPL3')
+depends=('attr' 'gtk3' 'perl-image-exiftool' 'python')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('41057ef4efb61a24cfb6cf70a2e45381542774635f5080803dba5ba0b5429444')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+}
+
+# vim: ts=2 sw=2 et: