summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2019-06-28 22:08:18 -0400
committerDaniel M. Capella2019-06-28 22:09:22 -0400
commit969744efe7706e5bc55146048a747bcdfd78bb5e (patch)
treee6f45e10fceb6b292feff8a557b192f94e16f4d7
parent40ac9af630c9c5d2b8aed2523c0cf672eb2e822d (diff)
downloadaur-969744efe7706e5bc55146048a747bcdfd78bb5e.tar.gz
2.4.0 and use upstream checksum
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33bcae670640..128a2ad69061 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = instalooter
pkgdesc = Another API-less Instagram pictures and videos downloader
- pkgver = 2.3.4
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/althonos/InstaLooter
arch = any
@@ -10,21 +10,20 @@ pkgbase = instalooter
checkdepends = python-parameterized
checkdepends = python-piexif
checkdepends = python-pillow
- makedepends = python-setuptools
depends = python-coloredlogs
depends = python-dateutil
depends = python-docopt
- depends = python-fake-useragent
depends = python-fs
depends = python-requests
+ depends = python-setuptools
depends = python-six
depends = python-tenacity
depends = python-tqdm
depends = python-verboselogs
optdepends = python-piexif: to add EXIF metadata to downloaded pictures
optdepends = python-pillow: to add EXIF metadata to downloaded pictures
- source = https://files.pythonhosted.org/packages/source/i/instalooter/instalooter-2.3.4.tar.gz
- sha512sums = ce9b47cbe0d8c182c26ca5943a5312b5401e20a664a3af0f2b5d564cbfb15c9645f915c55aee1d18f260a6ab35895759bebf4e397a529d758c83caa2b58856db
+ source = https://files.pythonhosted.org/packages/source/i/instalooter/instalooter-2.4.0.tar.gz
+ sha256sums = 7a50cea27bb813a5907f9377ed1faf144800cd3ffdd4d0a3c875f347f21d670e
pkgname = instalooter
diff --git a/PKGBUILD b/PKGBUILD
index d04cf0256399..ed5e670ba900 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=instalooter
-pkgver=2.3.4
+pkgver=2.4.0
pkgrel=1
pkgdesc='Another API-less Instagram pictures and videos downloader'
arch=('any')
url=https://github.com/althonos/InstaLooter
license=('GPL3')
depends=('python-coloredlogs' 'python-dateutil' 'python-docopt'
- 'python-fake-useragent' 'python-fs' 'python-requests' 'python-six'
+ 'python-fs' 'python-requests' 'python-setuptools' 'python-six'
'python-tenacity' 'python-tqdm' 'python-verboselogs')
-makedepends=('python-setuptools')
checkdepends=('python-contexter' 'python-mock' 'python-parameterized'
'python-piexif' 'python-pillow')
optdepends=('python-piexif: to add EXIF metadata to downloaded pictures'
'python-pillow: to add EXIF metadata to downloaded pictures')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha512sums=('ce9b47cbe0d8c182c26ca5943a5312b5401e20a664a3af0f2b5d564cbfb15c9645f915c55aee1d18f260a6ab35895759bebf4e397a529d758c83caa2b58856db')
+sha256sums=('7a50cea27bb813a5907f9377ed1faf144800cd3ffdd4d0a3c875f347f21d670e')
build() {
cd $pkgname-$pkgver
@@ -25,6 +24,9 @@ build() {
check() {
cd $pkgname-$pkgver
+ UA="Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0"
+ python -c "from instalooter.looters import InstaLooter; \
+ InstaLooter._cachefs.settext(u'user-agent.txt', u'$UA')"
python -m unittest discover
}