summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyles2015-07-09 14:26:57 +0100
committermyles2015-07-09 14:26:57 +0100
commitca5fbc87de46046b3fe050daca73791a494c6970 (patch)
tree63de6b2321e363fbc57876c0bae87da9628a9477
downloadaur-instant-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aeeee5003fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = instant-git
+ pkgdesc = A Python module allowing for instant inlining of C and C++ code in Python
+ pkgver = 20140523
+ pkgrel = 1
+ url = https://bitbucket.org/fenics-project/instant
+ arch = i686
+ arch = x86_64
+ groups = fenics-git
+ license = LGPL
+ depends = python2
+ depends = swig
+ provides = instant
+ conflicts = instant
+ options = !emptydirs
+ source = instant::git+https://bitbucket.org/fenics-project/instant.git#branch=master
+ md5sums = SKIP
+
+pkgname = instant-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82204bb4125b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Myles English <myles at rockhead dot biz>
+pkgname=instant-git
+pkgver=20140523
+pkgrel=1
+pkgdesc="A Python module allowing for instant inlining of C and C++ code in Python"
+_branch=master
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/fenics-project/instant"
+license=('LGPL')
+groups=('fenics-git')
+depends=('python2' 'swig')
+conflicts=('instant')
+provides=('instant')
+options=(!emptydirs)
+source=("instant::git+https://bitbucket.org/fenics-project/instant.git#branch=${_branch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd instant
+ git log --format="%cd" --date=short -1 | sed 's/-//g'
+}
+
+prepare() {
+ cd instant
+ find ./ -name "*" -type f -exec \
+ sed -i 's|^#!.*python$|#!/usr/bin/python2|' {} \;
+}
+
+build() {
+ cd instant
+ python2 setup.py build
+}
+
+package() {
+ cd instant
+ python2 setup.py install --root=$pkgdir
+}