summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelaun2020-10-21 21:51:45 +0200
committerKelaun2020-10-21 21:51:45 +0200
commit41509acd788efce5280906b277ccabde0f31f535 (patch)
treedfee03e255a5dfe28433d35b2067461e3d7d38c9
parent42062efd8b3f9da84002b747cf04f7811e54fb69 (diff)
downloadaur-41509acd788efce5280906b277ccabde0f31f535.tar.gz
Fixed an issue with the WA updater which would generate spurious updates
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a11155e15ec4..8d8198f3bf7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = instawow
pkgdesc = Package manager for World of Warcraft
- pkgver = 1.17.0
+ pkgver = 1.17.1
pkgrel = 1
url = https://github.com/layday/instawow
arch = x86_64
@@ -29,8 +29,8 @@ pkgbase = instawow
depends = python-yarl>=1.4.0
depends = python-slpp-git
optdepends = python-aiohttp_rpc: server support
- source = https://files.pythonhosted.org/packages/source/i/instawow/instawow-1.17.0.post1.tar.gz
- sha256sums = 0d3037e1dd958b9b7b9546cdf9151963863782d191f75af3728b7cc739ca29d4
+ source = https://files.pythonhosted.org/packages/source/i/instawow/instawow-1.17.1.tar.gz
+ sha256sums = 4ecaa6b14d8a9de42926937742b5975ac05feb6398f077150c4028c95d417216
pkgname = instawow
diff --git a/PKGBUILD b/PKGBUILD
index 23ab92c4e635..3190c8eb3286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kevin Andriessens <kevin@kelaun.be>
# Contributor: layday <layday@protonmail.com>
pkgname='instawow'
-pkgver='1.17.0'
+pkgver='1.17.1'
pkgrel=1
pkgdesc="Package manager for World of Warcraft"
arch=('x86_64')
@@ -11,20 +11,20 @@ depends=('python>=3.7.0' 'python-aiohttp=3.6.2' 'python-alembic>=1.4.3' 'python-
makedepends=('tar' 'python-setuptools' 'python-setuptools-scm' 'python-toml')
optdepends=('python-aiohttp_rpc: server support')
checkdepends=('python-pytest>=6.0.1' 'python-pytest<7.0.0' 'python-pytest-asyncio>=0.14.0' 'python-aresponses>=2.0.0')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.post1.tar.gz")
-sha256sums=('0d3037e1dd958b9b7b9546cdf9151963863782d191f75af3728b7cc739ca29d4')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('4ecaa6b14d8a9de42926937742b5975ac05feb6398f077150c4028c95d417216')
build() {
- cd "$pkgname-$pkgver.post1"
+ cd "$pkgname-$pkgver"
python setup.py build
}
check() {
- cd "$pkgname-$pkgver.post1"
+ cd "$pkgname-$pkgver"
PYTHONPATH="$PWD/build/lib" pytest --ignore tests/test_json_rpc_api.py --ignore tests/test_cli_output.py
}
package() {
- cd "$pkgname-$pkgver.post1"
+ cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}