summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-12 15:41:44 +0300
committervlad2015-07-12 15:41:44 +0300
commitbe9dd6b199f62bd77c77d45b0e0e4214fe5ee255 (patch)
tree5249b81d4a5da5f2b86e78861bcc76c29f306101
parentc43c48f273200a648202a3745baea6b8d5a7343e (diff)
downloadaur-be9dd6b199f62bd77c77d45b0e0e4214fe5ee255.tar.gz
Update to 1.2.16
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD39
2 files changed, 20 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef1a7f28a41b..ec729a1d4e74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = insync
pkgdesc = An unofficial Google Drive client that runs on Linux, with support for various desktops
- pkgver = 1.2.11
+ pkgver = 1.2.16
pkgrel = 1
url = https://www.insynchq.com/downloads
arch = i686
@@ -15,11 +15,14 @@ pkgbase = insync
optdepends = insync-thunar: file-manager integration for thunar
optdepends = insync-caja: file-manager integration for caja
optdepends = sni-qt: To show the icon in Plasma 5 tray
- noextract = insync-1.2.11.deb
options = !strip
options = !upx
source = insync.service
sha256sums = 995d9131bd454015ff11414d002b8927b7397835969e27061008264c0c5f225d
+ source_i686 = http://s.insynchq.com/builds/insync_1.2.16.35181-trusty_i386.deb
+ sha256sums_i686 = a98c318d2446aa8bd1939472386041d287559fd8dd79a3312c54dc591114a770
+ source_x86_64 = http://s.insynchq.com/builds/insync_1.2.16.35181-trusty_amd64.deb
+ sha256sums_x86_64 = 339eb3611e074599da83ddc39bfbc80c955a04988037a0f5c9e50e6728b57db3
pkgname = insync
diff --git a/PKGBUILD b/PKGBUILD
index 3aebb469efb5..7908541fb844 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
-# Maintainer: Zhengyu Xu <xzy3186@gmail.com>
+# Maintainer: Vlad M. <vlad@archlinux.net>
+# COntributor: Zhengyu Xu <xzy3186@gmail.com>
pkgname=insync
-pkgver=1.2.11
+pkgver=1.2.16
+_pkgver=35181
pkgrel=1
pkgdesc="An unofficial Google Drive client that runs on Linux, with support for various desktops"
url="https://www.insynchq.com/downloads"
license=('custom:insync')
options=(!strip !upx)
-
depends=('xdg-utils' 'glibc' 'python2')
optdepends=('insync-nautilus: file-manager integration for nautilus'
-'insync-nemo: file-manager integration for nemo'
-'insync-dolphin: file-manager integration for dolphin'
-'insync-thunar: file-manager integration for thunar'
-'insync-caja: file-manager integration for caja'
-'sni-qt: To show the icon in Plasma 5 tray'
-)
-
+ 'insync-nemo: file-manager integration for nemo'
+ 'insync-dolphin: file-manager integration for dolphin'
+ 'insync-thunar: file-manager integration for thunar'
+ 'insync-caja: file-manager integration for caja'
+ 'sni-qt: To show the icon in Plasma 5 tray')
arch=('i686' 'x86_64')
-if [ "$CARCH" = 'i686' ]; then
- source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}.35149-trusty_i386.deb")
- sha256sums=('85f9899a5748a806ec6267ffa0f5003b600af873159308134ef4d48e7130f0a5')
-elif [ "$CARCH" = "x86_64" ]; then
- source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}.35149-trusty_amd64.deb")
- sha256sums=('34244ac534ce0e508aa237ee2397b9617c6f80c3f4ac3bf68eaf452bfd58c8fe')
-fi
-noextract=("${pkgname}-${pkgver}.deb")
-
-source=("${source[@]}"
- "insync.service")
-sha256sums=("${sha256sums[@]}"
- "995d9131bd454015ff11414d002b8927b7397835969e27061008264c0c5f225d")
+source=('insync.service')
+source_i686=("http://s.insynchq.com/builds/${pkgname}_${pkgver}.${_pkgver}-trusty_i386.deb")
+source_x86_64=("http://s.insynchq.com/builds/${pkgname}_${pkgver}.${_pkgver}-trusty_amd64.deb")
+sha256sums=('995d9131bd454015ff11414d002b8927b7397835969e27061008264c0c5f225d')
+sha256sums_i686=('a98c318d2446aa8bd1939472386041d287559fd8dd79a3312c54dc591114a770')
+sha256sums_x86_64=('339eb3611e074599da83ddc39bfbc80c955a04988037a0f5c9e50e6728b57db3')
package() {
cd $srcdir
- ar x ${pkgname}-${pkgver}.deb
tar xvf data.tar.gz
cp -rp usr $pkgdir