summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2015-09-25 22:39:25 -0500
committerXavierCLL2015-09-25 22:39:25 -0500
commit86231ebb7d2e02940061096206c4304dc65cf79f (patch)
tree82f9bd686cce0267eda576ac8e65854aeb823bad
downloadaur-86231ebb7d2e02940061096206c4304dc65cf79f.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--insync-dolphin.install23
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..407f0fd7339d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = insync-dolphin
+ pkgdesc = Dolphin integration for insync (kf5)
+ pkgver = 1.2.8
+ pkgrel = 3
+ url = https://www.insynchq.com/downloads
+ install = insync-dolphin.install
+ arch = any
+ license = custom:insync
+ depends = insync
+ depends = kdebase-dolphin
+ noextract = insync-dolphin-1.2.8.deb
+ options = !strip
+ source = insync-dolphin-1.2.8.deb::http://s.insynchq.com/builds/insync-dolphin_1.2.8.35136-precise_all.deb
+ sha256sums = c2c2576739c93a3779e3bfc87ded5054523c9549ca9541ff5b810a84955f24a6
+
+pkgname = insync-dolphin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1640324594d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: XavierCLL
+
+pkgname=insync-dolphin
+pkgver=1.2.8
+pkgrel=3
+pkgdesc="Dolphin integration for insync (kf5)"
+url="https://www.insynchq.com/downloads"
+license=('custom:insync')
+options=(!strip)
+arch=('any')
+
+depends=("insync" "kdebase-dolphin")
+source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}.35136-precise_all.deb")
+sha256sums=('c2c2576739c93a3779e3bfc87ded5054523c9549ca9541ff5b810a84955f24a6')
+noextract=("${pkgname}-${pkgver}.deb")
+install=$pkgname.install
+
+package() {
+ cd $srcdir
+ ar x ${pkgname}-${pkgver}.deb
+ tar xvf data.tar.gz
+ install -Dm644 usr/share/kde4/services/ServiceMenus/insync_servicemenu.desktop "$pkgdir/usr/share/kservices5/ServiceMenus/insync_servicemenu.desktop"
+}
diff --git a/insync-dolphin.install b/insync-dolphin.install
new file mode 100644
index 000000000000..25cd6638acb7
--- /dev/null
+++ b/insync-dolphin.install
@@ -0,0 +1,23 @@
+show_message() {
+ if [ -f /usr/share/kde4/services/ServiceMenus/insync-kde-menu.desktop ]; then
+ echo ">>> If you use KDE, two optional plasmoids can be downloaded from here:"
+ echo ">>> http://s.insynchq.com/builds/insync.plasmoid"
+ echo ">>> http://s.insynchq.com/builds/gdrive_webview.plasmoid"
+ echo ">>> Help installing Plasmoids:"
+ echo ">>> http://userbase.kde.org/Plasma/Installing_Plasmoids"
+ fi
+ echo ">>> If you want to run insync daemon automatically on boot, please type:"
+ echo ">>> systemctl enable insync@<your_user_name>"
+}
+
+post_install() {
+ show_message
+}
+
+post_upgrade() {
+ show_message
+}
+
+post_remove() {
+ return 1
+}