summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:48:16 +0300
committervlad2015-07-08 15:48:16 +0300
commitc43c48f273200a648202a3745baea6b8d5a7343e (patch)
tree64f1ee0b8673e780d8241c4479ed7c719a8d7b28
downloadaur-c43c48f273200a648202a3745baea6b8d5a7343e.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
-rw-r--r--insync.service14
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef1a7f28a41b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = insync
+ pkgdesc = An unofficial Google Drive client that runs on Linux, with support for various desktops
+ pkgver = 1.2.11
+ pkgrel = 1
+ url = https://www.insynchq.com/downloads
+ arch = i686
+ arch = x86_64
+ license = custom:insync
+ depends = xdg-utils
+ depends = glibc
+ depends = python2
+ optdepends = insync-nautilus: file-manager integration for nautilus
+ optdepends = insync-nemo: file-manager integration for nemo
+ optdepends = insync-dolphin: file-manager integration for dolphin
+ optdepends = insync-thunar: file-manager integration for thunar
+ optdepends = insync-caja: file-manager integration for caja
+ optdepends = sni-qt: To show the icon in Plasma 5 tray
+ noextract = insync-1.2.11.deb
+ options = !strip
+ options = !upx
+ source = insync.service
+ sha256sums = 995d9131bd454015ff11414d002b8927b7397835969e27061008264c0c5f225d
+
+pkgname = insync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aebb469efb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Zhengyu Xu <xzy3186@gmail.com>
+
+pkgname=insync
+pkgver=1.2.11
+pkgrel=1
+pkgdesc="An unofficial Google Drive client that runs on Linux, with support for various desktops"
+url="https://www.insynchq.com/downloads"
+license=('custom:insync')
+options=(!strip !upx)
+
+depends=('xdg-utils' 'glibc' 'python2')
+optdepends=('insync-nautilus: file-manager integration for nautilus'
+'insync-nemo: file-manager integration for nemo'
+'insync-dolphin: file-manager integration for dolphin'
+'insync-thunar: file-manager integration for thunar'
+'insync-caja: file-manager integration for caja'
+'sni-qt: To show the icon in Plasma 5 tray'
+)
+
+arch=('i686' 'x86_64')
+if [ "$CARCH" = 'i686' ]; then
+ source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}.35149-trusty_i386.deb")
+ sha256sums=('85f9899a5748a806ec6267ffa0f5003b600af873159308134ef4d48e7130f0a5')
+elif [ "$CARCH" = "x86_64" ]; then
+ source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}.35149-trusty_amd64.deb")
+ sha256sums=('34244ac534ce0e508aa237ee2397b9617c6f80c3f4ac3bf68eaf452bfd58c8fe')
+fi
+noextract=("${pkgname}-${pkgver}.deb")
+
+source=("${source[@]}"
+ "insync.service")
+sha256sums=("${sha256sums[@]}"
+ "995d9131bd454015ff11414d002b8927b7397835969e27061008264c0c5f225d")
+
+package() {
+ cd $srcdir
+ ar x ${pkgname}-${pkgver}.deb
+ tar xvf data.tar.gz
+ cp -rp usr $pkgdir
+
+ cd $pkgdir
+ for file in $(grep -R "/usr/bin/python" . | cut -f1 -d :)
+ do
+ sed -i "s|usr/bin/python$|usr/bin/python2|g" $file
+ done
+ mkdir -p ${pkgdir}/usr/lib/systemd/system
+ sed "s/_OPTION/ start/g" ${srcdir}/insync.service >${pkgdir}/usr/lib/systemd/system/insync@.service
+}
diff --git a/insync.service b/insync.service
new file mode 100644
index 000000000000..beaf8528a8f2
--- /dev/null
+++ b/insync.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Insync
+After=local-fs.target network.target
+
+[Service]
+Environment=DISPLAY=:0
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/bin/insync_OPTION
+ExecStop=/usr/bin/insync quit
+User=%I
+
+[Install]
+WantedBy=multi-user.target