summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2017-09-08 12:09:51 -0700
committerAnatol Pomozov2017-09-08 12:12:27 -0700
commit3a196616071138586ef9cfbe09d10ef723c3d26c (patch)
tree7b6e5f43a46401726b1566188c5ef8c6756833b4
parent7733c9e54abf20e6a39cc2217ab7a4b8d0b4d4e2 (diff)
downloadaur-intel-me-tools-git.tar.gz
updpkg
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--linux_fixes.patch30
3 files changed, 6 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d51459eceb8..8b03edcddfde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = intel-me-tools-git
pkgdesc = Tools for working with Intel ME
- pkgver = r9.73b5624
+ pkgver = r27.b35da19
pkgrel = 1
url = https://github.com/skochinsky/me-tools
arch = any
license = unknown
depends = python2
- source = linux_fixes.patch
source = git+https://github.com/skochinsky/me-tools
- md5sums = 5b282b95bef7692fded0558a98342f0e
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = intel-me-tools-git
diff --git a/PKGBUILD b/PKGBUILD
index e08aa475e306..b606b137c7b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintrainer: Anatol Pomozov
pkgname=intel-me-tools-git
-pkgver=r9.73b5624
+pkgver=r27.b35da19
pkgrel=1
pkgdesc='Tools for working with Intel ME'
arch=(any)
url='https://github.com/skochinsky/me-tools'
license=(unknown)
depends=(python2)
-source=(linux_fixes.patch
- git+https://github.com/skochinsky/me-tools)
-md5sums=('5b282b95bef7692fded0558a98342f0e'
- 'SKIP')
+source=(git+https://github.com/skochinsky/me-tools)
+sha1sums=('SKIP')
pkgver() {
cd me-tools
@@ -20,7 +18,7 @@ pkgver() {
prepare() {
cd me-tools
- patch -p1 < ../linux_fixes.patch
+ sed -i 's/env python$/env python2/' me_unpack.py
}
package() {
diff --git a/linux_fixes.patch b/linux_fixes.patch
deleted file mode 100644
index 427000b85c41..000000000000
--- a/linux_fixes.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/me_unpack.py b/me_unpack.py
-index c7d4f7e..86b3f8f 100644
---- a/me_unpack.py
-+++ b/me_unpack.py
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python2
- # Intel ME ROM image dumper/extractor
- # Copyright (c) 2012-2014 Igor Skochinsky
- # Version 0.1 2012-10-10
-@@ -287,10 +288,7 @@ def extract_code_mods(nm, f, soff):
-
-
- def decomp_lzma(compdata):
-- import subprocess, _subprocess
-- # hide the console window
-- si = subprocess.STARTUPINFO()
-- si.dwFlags |= _subprocess.STARTF_USESHOWWINDOW
-+ import subprocess
- if in_ida:
- basedir = idaapi.idadir("loaders")
- else:
-@@ -298,7 +296,7 @@ def decomp_lzma(compdata):
- path = os.path.join(basedir, "lzma")
- #print "using decompressor at '%s'" % path
- try:
-- process = subprocess.Popen([path, "d", "-si", "-so"], startupinfo=si, stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
-+ process = subprocess.Popen([path, "d", "-si", "-so"], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
- output, errout = process.communicate(compdata)
- retcode = process.poll()
- except IOError as e: