summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-05 00:34:11 +0000
committerDaniel Bermond2018-10-05 01:25:30 +0000
commite1ec6b005907a9c82673be6002aaa96d99c97fe9 (patch)
tree7be31001c68e5f803a50688e43555c7f5183b8da
parent23d73e453c8b4afde5529f4b6ce2b75a82adff4d (diff)
downloadaur-e1ec6b005907a9c82673be6002aaa96d99c97fe9.tar.gz
Match changes of the corresponding repository package
intel-media-driver and intel-gmmlib (formerly named gmmlib) packages are now on the [community] official repository. This commit will match the changes that were introduced in the corresponding repository packages, as follows: - pkgdesc: includes igpu target specification. - depends: update gmmlib-git package name to reflect the new one (intel-gmmlib-git). - Do not install the profile.d file. It means that the package do not to offer anymore a way to select the iHD driver. User needs to read the Arch Wiki and do their homework to select the iHD driver (Wiki page: currently at 'Hardware video acceleration'). Note: I have still kept the 'YYYY.x.x' pkgver format instead of adopting the new 'YY.x.x' one that is being currently used by upstream (and was adopted by the repository package). Upstream have made a mess with the versioning schema/method, altering it at each new major release. So I will be still waiting for '19.x.x' to see if they will keep it or change it again. Maybe I don't even change it at all in the future (this will not interfere with the corresponding repository package anyway). This also removes the need of adding an epoch number at this moment. Other changes in this commit: - pkgver(): cosmetic changes and better handling of year/major.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--intel-media-driver-git.install10
3 files changed, 8 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ef8cf7f5dc6..5eae01b61dc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = intel-media-driver-git
- pkgdesc = Intel Media Driver for VAAPI (git version)
- pkgver = 2018.3.pre2.r50.g0ed718d8
+ pkgdesc = Intel Media Driver for VAAPI — Broadwell+ iGPUs (git version)
+ pkgver = 2018.3.pre3.r106.g9a64b5e4
pkgrel = 1
url = https://github.com/intel/media-driver/
- install = intel-media-driver-git.install
arch = x86_64
license = MIT
license = BSD
@@ -11,11 +10,10 @@ pkgbase = intel-media-driver-git
makedepends = cmake
depends = gcc-libs
depends = libpciaccess
- depends = gmmlib-git
+ depends = intel-gmmlib-git
depends = libva-git
provides = intel-media-driver
conflicts = intel-media-driver
- backup = etc/profile.d/intel-media.sh
source = intel-media-driver-git::git+https://github.com/intel/media-driver.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b302ad884905..f3e71a1ffe36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=intel-media-driver-git
-pkgver=2018.3.pre2.r50.g0ed718d8
+pkgver=2018.3.pre3.r106.g9a64b5e4
pkgrel=1
-pkgdesc='Intel Media Driver for VAAPI (git version)'
+pkgdesc='Intel Media Driver for VAAPI — Broadwell+ iGPUs (git version)'
arch=('x86_64')
url='https://github.com/intel/media-driver/'
license=('MIT' 'BSD')
@@ -11,13 +11,11 @@ depends=(
# official repositories:
'gcc-libs' 'libpciaccess'
# AUR:
- 'gmmlib-git' 'libva-git'
+ 'intel-gmmlib-git' 'libva-git'
)
makedepends=('git' 'cmake')
provides=('intel-media-driver')
conflicts=('intel-media-driver')
-backup=('etc/profile.d/intel-media.sh')
-install="${pkgname}.install"
source=("$pkgname"::'git+https://github.com/intel/media-driver.git')
sha256sums=('SKIP')
@@ -25,8 +23,7 @@ pkgver() {
cd "$pkgname"
# git, tags available
- local _prefix='intel-media-'
- git describe --long --tags | sed "s/^${_prefix}//;s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/^18\./2018./"
+ git describe --long --tags | sed 's/^intel-media-//;s/^[0-9]\{2\}/20&/;s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
@@ -36,7 +33,7 @@ build() {
cmake \
-DCMAKE_INSTALL_LIBDIR:PATH='lib' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DCMAKE_INSTALL_SYSCONFDIR:PATH='etc' \
+ -DINSTALL_DRIVER_SYSCONF:BOOL='OFF' \
-Wno-dev \
../"$pkgname"
@@ -48,11 +45,6 @@ package() {
make DESTDIR="$pkgdir" install
- # do not force the use of 'iHD' libva driver by default (let user choose)
- local _info='# uncomment the LIBVA_DRIVER_NAME line to use the Intel Media Driver (iHD) for VAAPI'
- sed -i "2i${_info}" "${pkgdir}/etc/profile.d/intel-media.sh"
- sed -i '/^export[[:space:]]LIBVA_DRIVER_NAME/s/^/#/' "${pkgdir}/etc/profile.d/intel-media.sh"
-
# license
cd "${srcdir}/${pkgname}"
install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/intel-media-driver-git.install b/intel-media-driver-git.install
deleted file mode 100644
index 31340bc810c1..000000000000
--- a/intel-media-driver-git.install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_install() {
- printf '%s\n' 'In order to use the the Intel Media Driver for VAAPI you need to set the'
- printf '%s\n' "'LIBVA_DRIVER_NAME' environment variable to 'iHD'. You can do this, for"
- printf '%s\n' "example, by uncommenting the proper line in '/etc/profile.d/intel-media.sh'"
- printf '%s\n' '(relogin after).'
-}
-
-post_upgrade() {
- post_install
-}